summaryrefslogtreecommitdiff
path: root/dev-python/pygdbmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 22:56:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 22:56:13 +0000
commit3652885475bb4bf8de9f4f8e06553d5dbd4dd03d (patch)
tree50643bb9e9c6a0980edbdd0a6e1431f3af997328 /dev-python/pygdbmi
parentd602f48b0029adc0d2ad1fceed902419909e98ac (diff)
gentoo auto-resync : 02:12:2023 - 22:56:13
Diffstat (limited to 'dev-python/pygdbmi')
-rw-r--r--dev-python/pygdbmi/Manifest3
-rw-r--r--dev-python/pygdbmi/metadata.xml20
-rw-r--r--dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild31
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pygdbmi/Manifest b/dev-python/pygdbmi/Manifest
new file mode 100644
index 000000000000..3c75b2626337
--- /dev/null
+++ b/dev-python/pygdbmi/Manifest
@@ -0,0 +1,3 @@
+DIST pygdbmi-0.11.0.0.gh.tar.gz 30784 BLAKE2B a3d6bc51640dac78c072ef0162bc1d546707f1b220d8d695595d05a5bcdea8b31b5e23ad916cd2a58bbd4bec2f9fd32b6a9294f00957d890fefd0ecf457ed0de SHA512 11bbc0a9353dbb9d96cb9c71d45a68de446ac6cf1cd110b8f508143218783d2cdfa685874a9b9483933fc58fcfcbb7524a3b670d1c8a6117e8d6484586f1ced6
+EBUILD pygdbmi-0.11.0.0.ebuild 617 BLAKE2B 1aaf8b181f86eb663d46734f92e2c089220a84b52314e2865cbc43a74de640cb9096b8d735782f779d4f5ae4ed1b86231d017e2d41602acf4af8811be7c87ff1 SHA512 fb77aaf25455eb30d211754fe63047390c2932ab80d0ad75af5d6aaaffec44e87ade3c5d3858687fdf412023b9d17552784e99d17a54a8751c40c08d3352e576
+MISC metadata.xml 610 BLAKE2B 9b0a34853bec5f20469c24916ba92d55c95ea96f37897ceebe63db3b2a005fcdf8d107d8eb46a9e8139dee13d137d6e7597f80ce6c04daf3238389758d266f53 SHA512 142807add15f2010b6bedfdb0500ca1a3afa2febf2e47339a48f4fbf70d0ba5ff0df48333a62469166773d64d034d7245771900faf004e3bfd026a601def50df
diff --git a/dev-python/pygdbmi/metadata.xml b/dev-python/pygdbmi/metadata.xml
new file mode 100644
index 000000000000..23ce86c5a4bc
--- /dev/null
+++ b/dev-python/pygdbmi/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">cs01/pygdbmi</remote-id>
+ <remote-id type="pypi">pygdbmi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild b/dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild
new file mode 100644
index 000000000000..f8f64e32f951
--- /dev/null
+++ b/dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to parse gdb mi output and interact with gdb subprocesses"
+HOMEPAGE="
+ https://cs01.github.io/pygdbmi/
+ https://github.com/cs01/pygdbmi/
+ https://pypi.org/project/pygdbmi/
+"
+# no tests in sdist
+SRC_URI="
+ https://github.com/cs01/pygdbmi/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=sys-devel/gdb-9.6
+"
+
+distutils_enable_tests pytest