summaryrefslogtreecommitdiff
path: root/dev-python/pyglet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyglet
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyglet')
-rw-r--r--dev-python/pyglet/Manifest3
-rw-r--r--dev-python/pyglet/metadata.xml21
-rw-r--r--dev-python/pyglet/pyglet-1.2.4.ebuild41
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
new file mode 100644
index 000000000000..bfcb27893c02
--- /dev/null
+++ b/dev-python/pyglet/Manifest
@@ -0,0 +1,3 @@
+DIST pyglet-1.2.4.tar.gz 2122017 BLAKE2B 6e5e24ec78e24b9a9c8e9627791ede93d740c1af7af0176c6f75409c76981fa16752bbe14c9b5ec871438f5468b3587e7ce12194241d94ab3731d46cbbe395f1 SHA512 70cd781936db8c8c156499e524ee73520bc90c19461074264abd62a4854307ef090af5faba521686f247fb4cbee552a428892f59a5b382429acfc000f4c2e22d
+EBUILD pyglet-1.2.4.ebuild 983 BLAKE2B 8dd7849e691bc6ae58d8c4270454d833d71dafd56e87ea9163345d436ae371d3d81266f8ff1577a33c88a379f9dd754a018d6380d02217283138e84fb6a2084c SHA512 a9028893702ccd3c8d549f764b0fe05a8617e5b881c6403bf03b5ab22a166281b1e8d6f3d78573635bd1618f83380e6efab9b6666f3f2a71a4b18b0c196c2c9c
+MISC metadata.xml 893 BLAKE2B b2c9d0381d98ba205738e1fee69cb1a8952060c5d0095d134d84136af35fd38da8f81cca964a1ad748e615cb9c443b18f53a31f436a8356c83725423e16e8b64 SHA512 2bf1d8f350103309d98bda2834337acf488726e3ee141509f3423c46695c87d2a61557dec3d3c0e523815e09fd3d02eb3411779b4ce2fac05b83425401480269
diff --git a/dev-python/pyglet/metadata.xml b/dev-python/pyglet/metadata.xml
new file mode 100644
index 000000000000..85c37d9142f7
--- /dev/null
+++ b/dev-python/pyglet/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">This library provides an object-oriented programming interface
+ for developing games and other visually-rich applications with Python.
+ pyglet has virtually no external dependencies. For most applications
+ and game requirements, pyglet needs nothing else besides Python,
+ simplifying distribution and installation. It also handles
+ multiple windows and fully aware of multi-monitor setups.
+ pyglet might be seen as an alternative to PyGame.</longdescription>
+ <upstream>
+ <remote-id type="pypi">pyglet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyglet/pyglet-1.2.4.ebuild b/dev-python/pyglet/pyglet-1.2.4.ebuild
new file mode 100644
index 000000000000..ef62a91fc9fa
--- /dev/null
+++ b/dev-python/pyglet/pyglet-1.2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="http://www.pyglet.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="alsa examples gtk +openal"
+
+RDEPEND="
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib[alisp] )
+ gtk? ( x11-libs/gtk+:2 )
+ openal? ( media-libs/openal )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# ffmpeg? ( media-libs/avbin-bin )
+
+# pyglet.gl.glx_info.GLXInfoException: pyglet requires an X server with GLX
+RESTRICT=test
+
+python_test() {
+ python_is_python3 && return
+ VIRTUALX_COMMAND="${PYTHON}"
+ virtualmake tests/test.py
+}
+
+python_install_all() {
+ DOCS=( NOTICE )
+ use examples && EXAMPLES=( examples )
+ distutils-r1_python_install_all
+}