summaryrefslogtreecommitdiff
path: root/dev-python/pygobject/pygobject-3.36.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pygobject/pygobject-3.36.1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pygobject/pygobject-3.36.1.ebuild')
-rw-r--r--dev-python/pygobject/pygobject-3.36.1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/pygobject/pygobject-3.36.1.ebuild b/dev-python/pygobject/pygobject-3.36.1.ebuild
index b4bc8e3bab46..16c018529420 100644
--- a/dev-python/pygobject/pygobject-3.36.1.ebuild
+++ b/dev-python/pygobject/pygobject-3.36.1.ebuild
@@ -27,11 +27,14 @@ RDEPEND="${PYTHON_DEPS}
"
DEPEND="${RDEPEND}
test? (
- dev-libs/atk[introspection]
- dev-python/pytest[${PYTHON_USEDEP}]
- x11-libs/gdk-pixbuf:2[introspection,jpeg]
- x11-libs/gtk+:3[introspection]
- x11-libs/pango[introspection] )
+ $(python_gen_cond_dep '
+ dev-libs/atk[introspection]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection,jpeg]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ ' -3)
+ )
"
BDEPEND="
virtual/pkgconfig
@@ -59,6 +62,11 @@ src_test() {
local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
testing() {
+ if ! python_is_python3; then
+ einfo "Skipping tests on Python 2 to unblock deps"
+ return
+ fi
+
local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
meson_src_test || die "test failed for ${EPYTHON}"
}