summaryrefslogtreecommitdiff
path: root/dev-python/pygpu/pygpu-0.6.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pygpu/pygpu-0.6.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pygpu/pygpu-0.6.7.ebuild')
-rw-r--r--dev-python/pygpu/pygpu-0.6.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pygpu/pygpu-0.6.7.ebuild b/dev-python/pygpu/pygpu-0.6.7.ebuild
new file mode 100644
index 000000000000..71838169b36f
--- /dev/null
+++ b/dev-python/pygpu/pygpu-0.6.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MYPV=${PV/_/-}
+
+DESCRIPTION="Python bindings to libgpuarray"
+HOMEPAGE="http://deeplearning.net/software/libgpuarray/"
+SRC_URI="https://github.com/Theano/libgpuarray/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda opencl test"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/libgpuarray:=[cuda?,opencl?]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/libgpuarray-${MYPV}"
+
+python_test() {
+ local DEVICE=cuda
+ use opencl && DEVICE=opencl
+ nosetests -svw "${BUILD_DIR}/lib/" || die
+}