summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pygraphviz
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest4
-rw-r--r--dev-python/pygraphviz/metadata.xml1
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.8.ebuild42
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index d66a683377cd..c30fb7b9bfff 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1,3 +1,5 @@
DIST pygraphviz-1.7.zip 118754 BLAKE2B 36507fc862bec45a33bee3f89e7593a15639e7d98067e1c4ddf917558b7bc037b9d7607f7f017ad5980ba0e6805e63f05464efe8fd416ef70cb95709151714e3 SHA512 09438931d1930a70f7da94b0a12b449c0836ad707c6c8abed49bae0db162c136002d170398ed02dc56a5029269490ce3156d2d4b0f30602a11165bc0038998ea
+DIST pygraphviz-1.8.zip 119640 BLAKE2B a5c035085c503a06b0496a7ea4db0861e703d2811ab415f2d528dbc6c342d0fab1e9294f818cc4e49bdebba1b98456d6f34eea5628735193a6dde2c37035afce SHA512 f59d9452867167ba406d0e352700ec6bc80364318413a982eadb324c7817f92b9d09922b5fd90b603e2cf6f408390f862e003ef3f1fd3230390944f7d6ee7228
EBUILD pygraphviz-1.7.ebuild 1015 BLAKE2B dfbf154b3335a6198854756b3d45fbd1fa6a905726d984678ac74dbce6cffaaa3a7ee2fda5572251bddccf1c6225624530e08b45f492ade483dd49b6bc8d5df2 SHA512 a2a270c8b0067e9f0a73e6a7dec9bab469162595ab725140b284f62aefeb768a2c40515ed32eedc10bf276d5bdbaead5d1ec86dc9728ff527214313b575c944c
-MISC metadata.xml 617 BLAKE2B 59bc33de44a549d6de892b17b55c5a923de2b0d3b547758345e744b62bdde6c77bcd69b9adea8091d68e53bad40dbf2512abc0c81403c368f0d6c4e28a07846b SHA512 5b9cfadaf8b671c35cc7ed7f6e6a546a11c833744d6cb0d52e5e39f4cc5fc10ca661389d39b4f95cb23f0cc926287a890dceb649c422f1b5271454f77d6ce200
+EBUILD pygraphviz-1.8.ebuild 975 BLAKE2B f13291bd9a6a7f3c724b7e2183573d3f907e76c9a00def180b0b827774a71f9cbe4f8802796d27c6f8d8e2e9373fb7c83756165ad2494e304debff565579bf45 SHA512 d9146219e833272cf946ab3616060811925385d4287baeb22ba56049fb2d747e4ae69fc02592201ce10bcad7ec3d2825750b21bc9dbf16d236ceeed6ced2fabe
+MISC metadata.xml 680 BLAKE2B 8c27b9bad68a0cbad1f63ad26052eef28e3446b0833bd2f87600737e763c7438cc3ac3f956c0e2a7964a7962d63dc0b7c5cc0cd8e6d61e6eb653e78044f9dd45 SHA512 7ee41b408d35f114dacb3ab9fd4ccd846ea6a4c865266d9bcb58988c464a0282e9dd2e9dc2e6c3f5a264dc93d4ba59a2e0bf27e9003b97e02b37dede273e17da
diff --git a/dev-python/pygraphviz/metadata.xml b/dev-python/pygraphviz/metadata.xml
index e897a829e633..8551c9031058 100644
--- a/dev-python/pygraphviz/metadata.xml
+++ b/dev-python/pygraphviz/metadata.xml
@@ -13,5 +13,6 @@
</longdescription>
<upstream>
<remote-id type="pypi">pygraphviz</remote-id>
+ <remote-id type="github">pygraphviz/pygraphviz</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pygraphviz/pygraphviz-1.8.ebuild b/dev-python/pygraphviz/pygraphviz-1.8.ebuild
new file mode 100644
index 000000000000..cc40c444bcd8
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="https://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-lang/swig:0
+ test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/install || die
+ epytest
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}