summaryrefslogtreecommitdiff
path: root/dev-python/pygtkhelpers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pygtkhelpers
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pygtkhelpers')
-rw-r--r--dev-python/pygtkhelpers/Manifest3
-rw-r--r--dev-python/pygtkhelpers/metadata.xml11
-rw-r--r--dev-python/pygtkhelpers/pygtkhelpers-0.4.3-r1.ebuild52
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pygtkhelpers/Manifest b/dev-python/pygtkhelpers/Manifest
new file mode 100644
index 000000000000..1b1d9f0df03e
--- /dev/null
+++ b/dev-python/pygtkhelpers/Manifest
@@ -0,0 +1,3 @@
+DIST pygtkhelpers-0.4.3.tar.gz 118768 BLAKE2B 13736a8e38e435940845b55cf81ab9422328b83ba0f8f84b40fb6d9506d4c04be2c133aca403a0d258f751aa9f65c83c56b83f8e92448add1fec63620c7bec0a SHA512 6736cb77ad7d5f8a9811d6604ef112ed73b27347fb4633c611d3cc77ac28a9b51e03b32a2ffb76fd94effae485b3d890699bdcc3726fcd6be509809045cb3830
+EBUILD pygtkhelpers-0.4.3-r1.ebuild 1114 BLAKE2B 40bbfea0711952bf59d41265070b1205d75228f73b3eec83efc4e2bb4af7fb2c0e34e48fc2c282b2a7950a0908373abff5fa65fc72c935a345c3b40638e5bfec SHA512 fdee5a23fdc341d7dfae4878dad3fa17407a8486ab15c4b06dcccc07b1b6a1451903328c9ecb747ead96f746a8b0b57aed5b103d414254f5db62ad42da50c35d
+MISC metadata.xml 315 BLAKE2B 433d7d132dae501a7e8b25f3aa40909cbd356b2820ac2cb392c2f3a19d8d29288386cc686e067708f9be5ad80cdc8253245a95432a0fc3e4d0dd80e341559faa SHA512 c9bf832b017bfbb4ee79d2553bdbc6fbcbe27f3ddb11d942ddb7f8fc82926cd442c322ed9a42410c6611e6bed9257d32476a3c87ff8f237d47c48e0244796ca8
diff --git a/dev-python/pygtkhelpers/metadata.xml b/dev-python/pygtkhelpers/metadata.xml
new file mode 100644
index 000000000000..1bc45847ec63
--- /dev/null
+++ b/dev-python/pygtkhelpers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pygtkhelpers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygtkhelpers/pygtkhelpers-0.4.3-r1.ebuild b/dev-python/pygtkhelpers/pygtkhelpers-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..eee4ec377aa1
--- /dev/null
+++ b/dev-python/pygtkhelpers/pygtkhelpers-0.4.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="PyGTKHelpers is a library to assist the building of PyGTK applications"
+HOMEPAGE="https://pythonhosted.org/pygtkhelpers/
+ https://pypi.org/project/pygtkhelpers/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )"
+
+python_prepare_all() {
+ # docs/_static/scope.jpg does not exist.
+ sed -e "s/^\(html_logo =.*\)/#\1/" -i docs/conf.py || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ cd "${BUILD_DIR}"/sphinx/html || die
+ docinto html
+ dodoc -r [a-z]* _images _static
+ cd - >/dev/null || die
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+}