summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
commit2e512e4e32285f8c4eb19586d014cb9d31454ec9 (patch)
treee5884cadbd260c6936495a63b92f4503d54e5428 /dev-python/pyhamcrest
parent5264c18a325553759d67fb4e059db03cf3fc5c81 (diff)
gentoo auto-resync : 19:02:2025 - 00:15:15
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest2
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild15
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index 48ba78e482d6..6c1c1bf2b32f 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,3 +1,3 @@
DIST PyHamcrest-2.1.0.gh.tar.gz 62526 BLAKE2B 5f4a836c6f0e61977fe0d572987a75fa9803d2362afb95d27d22aa8a567844823452b99c40c8160cca4407a60dbbeff3f6fdf03163da9ee643e082a64e83c512 SHA512 99017a75954b346622f9bd261a4f8827f82eb42a19551a7f96f9097a763e57afcc367a41a4cca742bda60ee0e7c3bcc2ca7025348e318f41e67c97c7a60961b5
-EBUILD pyhamcrest-2.1.0.ebuild 945 BLAKE2B ee8a98395fe8b4a4d981ec326a5428801096c49c2ee9f1019e3a98f525a572b07c889777fc832d337b7b78c4dfeef170f7bb6897b9c2b7d2c1ced80415954ebb SHA512 fd7b96c8584d963812037a974eaa2e7b02a68b6ed143a804d0034511b012dd7b2eb25a1f915b0068932e2660a6c55ae9d5f9d656a338babffd102955c645313f
+EBUILD pyhamcrest-2.1.0.ebuild 1327 BLAKE2B ae7b09f6d135cd3f6ddd516f6739b9cc26d3ca79276d37cbb042206b51ae0b10d9ed160111a72ddb9c1a1f2b114dcd8c9da60438fc0bd134aa5994c68c6db22e SHA512 69108026f544be443301c4e2b64c96d1c9030915d214bd4735fa2389ca6698abbfc4a8fa242805ecf237efa2cff35db4207b73a1ef06422e7ae7fcee76b92fdf
MISC metadata.xml 397 BLAKE2B cfdb950c34749dd9fa17d822df0194a8f35e477902947cf568f76aed96588c0e5a903ea5448f9772faef06ddc66df3c3c971978c6f4431861bf3586702d610db SHA512 024f24f466f0212a7ac599638bcd42b858e2cc786b7bf2641d0e0d4cc3df5dc97c958d4d85930cbd1c32e023f755f844a2675e2c820839729c54ad5e8fb40cd6
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
index 40ac59715027..1efb01e97990 100644
--- a/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
+++ b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
inherit distutils-r1
@@ -35,6 +35,17 @@ distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+python_test() {
+ local EPYTEST_DESELECT=(
+ # removed in numpy 2.0, https://github.com/hamcrest/PyHamcrest/pull/248
+ tests/hamcrest_unit_test/number/iscloseto_test.py::IsNumericTest::test_numpy_numeric_type_complex
+ tests/hamcrest_unit_test/number/iscloseto_test.py::IsNumericTest::test_numpy_numeric_type_float
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
python_install_all() {
use examples && dodoc -r examples
distutils-r1_python_install_all