summaryrefslogtreecommitdiff
path: root/dev-python/pyhcl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
commit374561aeaff53ce5a2836af934749923b4ea3763 (patch)
tree66880cb44879bf28002f361a4c862814df616b8f /dev-python/pyhcl
parentea0515fa73da4755b498bdb18bd7fd7a13e616cf (diff)
gentoo auto-resync : 20:01:2023 - 23:41:20
Diffstat (limited to 'dev-python/pyhcl')
-rw-r--r--dev-python/pyhcl/Manifest4
-rw-r--r--dev-python/pyhcl/pyhcl-0.4.4-r1.ebuild (renamed from dev-python/pyhcl/pyhcl-0.4.4.ebuild)14
2 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/pyhcl/Manifest b/dev-python/pyhcl/Manifest
index da76f7a1b57b..2332f60b3989 100644
--- a/dev-python/pyhcl/Manifest
+++ b/dev-python/pyhcl/Manifest
@@ -1,3 +1,3 @@
-DIST pyhcl-0.4.4.tar.gz 58400 BLAKE2B 89ce8ba1eff577d9b4c7a86931e305f94ad7633b83c27f44352658ec2a12e48fd0cb05619e4afd97e4f2d78a9f4dba5c082a0d5703060b629880a3d193d9b4ee SHA512 7c5e2b611d1198a0e6c667b8fda868231bdd25da822d634a34c076fea655a7ea2999fc827de8484992efcf52b6b843871713a83e3be7787003c90f05e3e7ddf6
-EBUILD pyhcl-0.4.4.ebuild 809 BLAKE2B 3fd2808ffc52362c457ca8e5f31dc7fd6512dd725611585578a90b4abb2a82275c7020758753d55ecd03922692b368d3fea1dd69a299bbdf2db72d4267f76b56 SHA512 7a5118f572d080fba8243a919cb81d6851ddd3ee0aacb53161a3397e1799527ce8ce3ea65450f2a924893659cd8a3a691c4a7ceb4d21b09dffc9961ff287a7e2
+DIST pyhcl-0.4.4.gh.tar.gz 58400 BLAKE2B 89ce8ba1eff577d9b4c7a86931e305f94ad7633b83c27f44352658ec2a12e48fd0cb05619e4afd97e4f2d78a9f4dba5c082a0d5703060b629880a3d193d9b4ee SHA512 7c5e2b611d1198a0e6c667b8fda868231bdd25da822d634a34c076fea655a7ea2999fc827de8484992efcf52b6b843871713a83e3be7787003c90f05e3e7ddf6
+EBUILD pyhcl-0.4.4-r1.ebuild 700 BLAKE2B a71e4d26d5f689d771555f62eef5275d82aebaf98e4ca77a6d81cef9da76ff97285e9e3ab5224b209c5b58134ae1a5cc0924252fd237e7634d35d07d931cc9a4 SHA512 7983c99330da1eb72674dffb6cf3c4f6e23bdfa9324896307f030e01b15e7feca15ec2caa7b84d548c6a2fa3b1bf52d1964f1cd32da8eccdcb64774f03e95d40
MISC metadata.xml 505 BLAKE2B 83658ee21302c885aae91af9c83ba041a4884ddabf718987c5b41fb7b1d8aaf0808e6413fc5bd0a829267c7498d83f2461329990d6d7e01c7b5cf5189067063f SHA512 d3120947df45964f58852355058c9ac23dd306466ef785b8115f6fc9eef91ee7ae6634fa1e1732f0f99e84961af942f3e319b51d7a380bf5835fe05c25ab6ee5
diff --git a/dev-python/pyhcl/pyhcl-0.4.4.ebuild b/dev-python/pyhcl/pyhcl-0.4.4-r1.ebuild
index dac65ed9f6f3..c7c457c0ad35 100644
--- a/dev-python/pyhcl/pyhcl-0.4.4.ebuild
+++ b/dev-python/pyhcl/pyhcl-0.4.4-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-# This value is obtained by running the following on the checked out
-# tag:
-# git describe --tags --long
-LONG_VERSION=0.4.4-0-g314cd32
-PYTHON_COMPAT=( python3_{9..10} )
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="HCL configuration parser for python"
@@ -16,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/virtuald/pyhcl.git"
else
- SRC_URI="https://github.com/virtuald/pyhcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/virtuald/pyhcl/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64 ~arm64"
fi
@@ -26,6 +24,6 @@ SLOT="0"
distutils_enable_tests pytest
python_prepare_all() {
+ printf '__version__ = "%s"\n' "${PV}" > src/hcl/version.py || die
distutils-r1_python_prepare_all
- printf '__version__ = "%s"\n' "${LONG_VERSION}" > src/hcl/version.py || die
}