summaryrefslogtreecommitdiff
path: root/dev-python/pyhcl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyhcl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyhcl')
-rw-r--r--dev-python/pyhcl/Manifest5
-rw-r--r--dev-python/pyhcl/metadata.xml11
-rw-r--r--dev-python/pyhcl/pyhcl-0.2.3.ebuild30
-rw-r--r--dev-python/pyhcl/pyhcl-0.3.6.ebuild30
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pyhcl/Manifest b/dev-python/pyhcl/Manifest
new file mode 100644
index 000000000000..81bddf8143cf
--- /dev/null
+++ b/dev-python/pyhcl/Manifest
@@ -0,0 +1,5 @@
+DIST pyhcl-0.2.3.tar.gz 21796 BLAKE2B f9e76ca40d49d8ce3cbb7ebcb18f731599d061986a44641488af46bcb7e1ebbac0e775502958efef2d4af1efc996497a834aaf89272d8d6bc8bb167a6be5febc SHA512 09cc9dd53048170ad49794d0944acaacba2c08bc5a05bb8d699bb47dc0a03eb32881ddf4dc0771e8b6ee008f7a47b5e95beed4bd77b173c88c6cc322eff4678f
+DIST pyhcl-0.3.6.tar.gz 23682 BLAKE2B 0c6cd819a14c5488e303fc5931bffa885e7d7de352570fc2ea9cba22ec4758dad3f69b5e62ba9186c57bfc7cc6add8cc9e0fec52e6dc870dfa1c7b26fca6e0d2 SHA512 27cb190947162e62766f7f4e33b1fbda8ac6a9750418b17cb8d9fa2b9fd0de28fc3e2c9d27f59af7c4740239794e9c81148b7ef20ad8f5d4fb59348c0cf9c5e8
+EBUILD pyhcl-0.2.3.ebuild 647 BLAKE2B 2244168de1cd22970319f206ef31b1bcd95137c70f0629d1ddcea630a8a4b76682e80b42429a26a47246ec6be09899c09d635fa093fac7b6ab743a469ecb6d68 SHA512 7ed2978263b9fc2a3a47ce546eee51ae329ea081f6c564c3aeb380a877ddff1b8187b57aa03a249021c41aa32f6b6d09bf0dbe7294091a795a04f4e6c9511a62
+EBUILD pyhcl-0.3.6.ebuild 647 BLAKE2B 2244168de1cd22970319f206ef31b1bcd95137c70f0629d1ddcea630a8a4b76682e80b42429a26a47246ec6be09899c09d635fa093fac7b6ab743a469ecb6d68 SHA512 7ed2978263b9fc2a3a47ce546eee51ae329ea081f6c564c3aeb380a877ddff1b8187b57aa03a249021c41aa32f6b6d09bf0dbe7294091a795a04f4e6c9511a62
+MISC metadata.xml 319 BLAKE2B 031effabad2704b3a367b95ea2065bc003e5df6575cba63b83a786450e45d3969d4eccac42fa4a413e8484ba60fd25e9028efa05cd3d697cfad1f15c60295279 SHA512 dffa813a0f0b7c76a978c1321d13723b440392647bd2cdbf26366d9fb2d7c572d4b726797cc61c249f25dac38ce9df9d71ef5de517b513b6ac3000ef72e06640
diff --git a/dev-python/pyhcl/metadata.xml b/dev-python/pyhcl/metadata.xml
new file mode 100644
index 000000000000..be257e4aabf9
--- /dev/null
+++ b/dev-python/pyhcl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">virtuald/pyhcl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyhcl/pyhcl-0.2.3.ebuild b/dev-python/pyhcl/pyhcl-0.2.3.ebuild
new file mode 100644
index 000000000000..a21ac72f71bc
--- /dev/null
+++ b/dev-python/pyhcl/pyhcl-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="HCL configuration parser for python"
+HOMEPAGE="https://github.com/virtuald/pyhcl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/ply-3.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e "s/==.*$//" requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die
+}
diff --git a/dev-python/pyhcl/pyhcl-0.3.6.ebuild b/dev-python/pyhcl/pyhcl-0.3.6.ebuild
new file mode 100644
index 000000000000..a21ac72f71bc
--- /dev/null
+++ b/dev-python/pyhcl/pyhcl-0.3.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="HCL configuration parser for python"
+HOMEPAGE="https://github.com/virtuald/pyhcl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/ply-3.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e "s/==.*$//" requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die
+}