summaryrefslogtreecommitdiff
path: root/dev-python/pyhcl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pyhcl
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pyhcl')
-rw-r--r--dev-python/pyhcl/Manifest3
-rw-r--r--dev-python/pyhcl/metadata.xml17
-rw-r--r--dev-python/pyhcl/pyhcl-0.4.4.ebuild31
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyhcl/Manifest b/dev-python/pyhcl/Manifest
new file mode 100644
index 000000000000..14e797402b0c
--- /dev/null
+++ b/dev-python/pyhcl/Manifest
@@ -0,0 +1,3 @@
+DIST pyhcl-0.4.4.tar.gz 58400 BLAKE2B 89ce8ba1eff577d9b4c7a86931e305f94ad7633b83c27f44352658ec2a12e48fd0cb05619e4afd97e4f2d78a9f4dba5c082a0d5703060b629880a3d193d9b4ee SHA512 7c5e2b611d1198a0e6c667b8fda868231bdd25da822d634a34c076fea655a7ea2999fc827de8484992efcf52b6b843871713a83e3be7787003c90f05e3e7ddf6
+EBUILD pyhcl-0.4.4.ebuild 806 BLAKE2B 0be078a5df5857c1e7425f9bda2db0a2234bde032a3ee103aaa5563aa949ebaffdfa0e08d0b35b07f2e17ca456267cc1b761d7f2d67499b886926f92c50d5e61 SHA512 a36b63dfcb1f91bdbfc4b7d44d60e2477faf06054c03cb2443ac1aaccd01ea217b661acaef2ab9d61245963561d1ffc78a9162515011879879c0fd0ac65373d7
+MISC metadata.xml 504 BLAKE2B 829a8f8466ea2164836482d43073fdbcf8eee25aa17999b1f5ddd36971dff10fc9e42cc7c1b4a5c6be72bb6307f46c40bb657afa8760659e9fbad0b38142fb33 SHA512 7ca7aac67d55ac7594e805cbb493285d69bd751a30bb127713f736f0c1b2f1d5b795fa48001b3544c920512e3b791b3bb2303647ce62d94781bfa279afe4dd26
diff --git a/dev-python/pyhcl/metadata.xml b/dev-python/pyhcl/metadata.xml
new file mode 100644
index 000000000000..294c6ef72555
--- /dev/null
+++ b/dev-python/pyhcl/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">virtuald/pyhcl</remote-id>
+ <remote-id type="pypi">pyhcl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyhcl/pyhcl-0.4.4.ebuild b/dev-python/pyhcl/pyhcl-0.4.4.ebuild
new file mode 100644
index 000000000000..f3342b15ce58
--- /dev/null
+++ b/dev-python/pyhcl/pyhcl-0.4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# This value is obtained by running the following on the checked out
+# tag:
+# git describe --tags --long
+LONG_VERSION=0.4.4-0-g314cd32
+PYTHON_COMPAT=( python3_8 python3_9 )
+inherit distutils-r1
+
+DESCRIPTION="HCL configuration parser for python"
+HOMEPAGE="https://github.com/virtuald/pyhcl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/virtuald/pyhcl.git"
+else
+ SRC_URI="https://github.com/virtuald/pyhcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ printf '__version__ = "%s"\n' "${LONG_VERSION}" > src/hcl/version.py || die
+}