summaryrefslogtreecommitdiff
path: root/dev-python/pyicu/pyicu-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /dev-python/pyicu/pyicu-2.0.2.ebuild
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'dev-python/pyicu/pyicu-2.0.2.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyicu/pyicu-2.0.2.ebuild b/dev-python/pyicu/pyicu-2.0.2.ebuild
new file mode 100644
index 000000000000..1e6ff018f986
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="PyICU"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/icu"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest
+ dev-python/six )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(CHANGES CREDITS README.md)
+
+python_test() {
+ esetup.py test
+}