summaryrefslogtreecommitdiff
path: root/dev-python/pyicu/pyicu-2.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
commitbb17db5f98333b3c74b4194d1c1136144f693add (patch)
tree65d7446b00fbeb21e2dd8dc4c106526dd4a8fb7d /dev-python/pyicu/pyicu-2.10.ebuild
parent1e9275d80771f014d7754407ca8ab9d7c43247b0 (diff)
gentoo auto-resync : 24:10:2022 - 09:51:42
Diffstat (limited to 'dev-python/pyicu/pyicu-2.10.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyicu/pyicu-2.10.ebuild b/dev-python/pyicu/pyicu-2.10.ebuild
new file mode 100644
index 000000000000..28f46b028f2e
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/
+"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest