summaryrefslogtreecommitdiff
path: root/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
commitfa1962ff69701bd9c0f15fb225cdbfb487125e0e (patch)
tree85b35bd5a3c73ea562768237a25da176adef5744 /dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
parentbd8ca999980e9c0c9ae40a11789c858bb58769e3 (diff)
gentoo auto-resync : 15:07:2022 - 19:43:32
Diffstat (limited to 'dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild')
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..79b5872dce8c
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="
+ https://pypi.org/project/pyinotify/
+ https://github.com/seb-m/pyinotify/"
+SRC_URI="https://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ if use examples; then
+ dodoc -r python3/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}