summaryrefslogtreecommitdiff
path: root/dev-python/pyinotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyinotify
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyinotify')
-rw-r--r--dev-python/pyinotify/Manifest3
-rw-r--r--dev-python/pyinotify/metadata.xml8
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6.ebuild27
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyinotify/Manifest b/dev-python/pyinotify/Manifest
new file mode 100644
index 000000000000..4b142249d9ed
--- /dev/null
+++ b/dev-python/pyinotify/Manifest
@@ -0,0 +1,3 @@
+DIST pyinotify-0.9.6.tar.gz 60998 BLAKE2B 7fb55cfe5b2c02682b5842d95859a58f218ab591a4eee689b707e804c6fe8cde4cc1fb3dfbf54a044ff743deefa0ee5551bc6e27ca4dda1c608218a6c24597b2 SHA512 b52de43293b06b32236e90b7c33fac061f3095cd7d4aecec89a099d56020db1a85440ab9dcc8b521238c001fc49a1f37d1b16d621bc1acab4d7273aebcaadbc5
+EBUILD pyinotify-0.9.6.ebuild 781 BLAKE2B 354ec3639a21de1f43343ed0329aa437a983a770fa61cbafcef3a0cc198ad8a40fa7600b40e94eec7dfbe00733a2c8f9e22f953093e7c5e916f57d56aa85e756 SHA512 b1559f337afdf7e9832abf1ba55e2656772205fb45612fa5212b59424a51aca12a970cf5becad06fdd5ccdf88909e2d65dfa8326c993ad63875e3261a46631a1
+MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/dev-python/pyinotify/metadata.xml b/dev-python/pyinotify/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/dev-python/pyinotify/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyinotify/pyinotify-0.9.6.ebuild b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
new file mode 100644
index 000000000000..d5ee18702d13
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="http://trac.dbzteam.org/pyinotify https://pypi.org/project/pyinotify/"
+SRC_URI="http://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_install_all() {
+ use examples && local EXAMPLES=( python2/examples/. )
+ EXAMPLES+=( python3/examples/. )
+ distutils-r1_python_install_all
+}