summaryrefslogtreecommitdiff
path: root/dev-python/pyjwt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-python/pyjwt
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest2
-rw-r--r--dev-python/pyjwt/pyjwt-1.5.3.ebuild11
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 2b96de0c201b..839aba71281f 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,3 +1,3 @@
DIST PyJWT-1.5.3.tar.gz 73044 BLAKE2B ae2e3caec52ddd768d573e0398bbc355c6eedca238db9b1808ff1d723b9fdee0845cf119d78e561833fe770e5ec39000905cec43a5e96102865f60e204c72c22 SHA512 b25a9f6a04bd072020fcf00bb559b7560902adb79746fb880432c01fa356748238432f53f6b9a21db50ece3e59ed4c45ca3f48ecec0ca3c4095e6a739a5c150c
-EBUILD pyjwt-1.5.3.ebuild 1265 BLAKE2B b0288608cf84527d858af2f5313198807cf7fe6189a9d7e0c20335adc8aab0566ff8c4c11f12677f5a37ad02841e3fe6e27438be115720c40f015e3826622efd SHA512 f560fc4f5764cb250e5e055df542ee1d518bc15737cd6304720db3500a78a971bd3fb0a3005d0b2c3307485f6df5154f40875467512be0f03ab8932b36c12327
+EBUILD pyjwt-1.5.3.ebuild 1274 BLAKE2B aca14ed6abc283ac649ec62cf7eaff6cd1324cc2bf191d67ee67e8eea6a7ebcaa793756f1d1758d68a2f2ec2273640bca630cd27707abfd2bfa88c2e54a8a53f SHA512 76a505fe837f0d199960b90f699483b24c9a5da67c5632875f0a28090615e332a34a06c125cd0dfcb048c5355ed1ef45eff063433f76de0b1a4a2d81e965fbcd
MISC metadata.xml 374 BLAKE2B 29e7fb2995367400d4f8d836cda63346441ff6008ac4554cd06859827d92924d3c34f2fb9763291766014a364d1e02af1ae6412fb02d316c775c3c0c13dcb22e SHA512 87a019a49c2e355d19148214f8ac7212758f7a36f77e7b959d32df1146c145b764f93707fd7b45a8c5276209a66380c888670181bf78bc4d241d5a7294a032b4
diff --git a/dev-python/pyjwt/pyjwt-1.5.3.ebuild b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
index ae1f2157dead..4f508b7efe49 100644
--- a/dev-python/pyjwt/pyjwt-1.5.3.ebuild
+++ b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} pypy )
inherit distutils-r1 eutils
@@ -24,8 +24,6 @@ DEPEND="
test? (
>=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
)"
S="${WORKDIR}"/${MY_PN}-${PV}
@@ -34,11 +32,14 @@ python_prepare_all() {
find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
find . -name '*.pyc' -exec rm -f {} \; || die "Cleaing *.pyc failed"
+ # enables coverage, we don't need that
+ rm setup.cfg || die
+
distutils-r1_python_prepare_all
}
python_test() {
- esetup.py test
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}
pkg_postinst() {