summaryrefslogtreecommitdiff
path: root/dev-python/pykka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pykka
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pykka')
-rw-r--r--dev-python/pykka/Manifest3
-rw-r--r--dev-python/pykka/metadata.xml12
-rw-r--r--dev-python/pykka/pykka-1.2.1.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pykka/Manifest b/dev-python/pykka/Manifest
new file mode 100644
index 000000000000..362c4739aa50
--- /dev/null
+++ b/dev-python/pykka/Manifest
@@ -0,0 +1,3 @@
+DIST Pykka-1.2.1.tar.gz 46252 BLAKE2B 48d351924874c3a26436643aef1bdeede1dc008b1edad67a4dca5aa29b13d421fd1643d1e9ec23bbe9ba16e638911b382389df878a2b53f7826ebf3d9058adaf SHA512 22eaa735915e33146d8a3fa3f9dd5ea1dd608e7ad45ab21721a108b01ddf058b4cd00da67b762a95ede650c9ba1a79ee3d6fd22a491bc7ff348a56b7c0139cfd
+EBUILD pykka-1.2.1.ebuild 581 BLAKE2B 593c4aa07dbfba39f24d59ecee1e8bc840aab2d493b8b241b04561f29ec65cce23b7f7b22d56226beb41f47eda26adf4547a784d4b55791704361e41fe79f30a SHA512 08d73a425e60c6a31b5524c0f9c564d8d6c74f57c395e7e7923236599c199f20bdb3cf3504fd40652e981e9620b7d35e50285b00ecde6d05b78554263c15c3b2
+MISC metadata.xml 359 BLAKE2B e2f0a68605f91ad6a1239f96c9f7e9fe16a4bc822b2c9996989a3924e0e075d40ef9cf82ec0e6fc1957207e1a6a780b2f885f494357da4bed58a80cf80422fc5 SHA512 ee8b1752f919c781167279d93af37133f06610833603c9c837e84c4f24cf6fa4be66af29097eb738d827a38416d9dd373bc248c6669ef2e5d042162bce0d8f89
diff --git a/dev-python/pykka/metadata.xml b/dev-python/pykka/metadata.xml
new file mode 100644
index 000000000000..3c91ab54b97a
--- /dev/null
+++ b/dev-python/pykka/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Pykka</remote-id>
+ <remote-id type="github">jodal/pykka</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pykka/pykka-1.2.1.ebuild b/dev-python/pykka/pykka-1.2.1.ebuild
new file mode 100644
index 000000000000..b2d5ba0a8e20
--- /dev/null
+++ b/dev-python/pykka/pykka-1.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{4,5,6}})
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="https://www.pykka.org/en/latest/ https://github.com/jodal/pykka"
+SRC_URI="mirror://pypi/P/Pykka/Pykka-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/Pykka-${PV}
+
+python_test() {
+ nosetests -v || die
+}