summaryrefslogtreecommitdiff
path: root/dev-python/pylast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
commit4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (patch)
treee2f0118b102bf7e7ad852582d410adb43f13b035 /dev-python/pylast
parent4418da21bd05d610a3450f4aa75481785ca372a0 (diff)
gentoo auto-resync : 28:02:2025 - 19:27:52HEADmaster
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest2
-rw-r--r--dev-python/pylast/pylast-5.4.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 0906b135f28f..41a8dc29aa35 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,3 +1,5 @@
DIST pylast-5.3.0.tar.gz 41552 BLAKE2B 0d6fd60e02f6106cbbfe2027614d8d403c54ee1f749ea697dba7d863e7a1fc647f95d2ea341e1d0ecfa2900a1ae117920466bb8f8a0728c5a9dea6be8d1009f0 SHA512 b8d015d9d1452a650a6fc05019a145c2c5104c1acd0e296d7a9b536fd91710b4efe3dab2646b4b373ca13278fbdc385a64472829dfd1cf8980a22a5f2314afe9
+DIST pylast-5.4.0.tar.gz 44746 BLAKE2B c3c5ad87079c95e40120fae8a5f8cbf24ff4878e1880c1cd7e612978bbc41b34612fc2a75509e9029296f559d1a562e2b59899335c052d6dd8a731af56dc3388 SHA512 2d4b4cd19c9d1a8726ce95565e3943d6c7f2fb4420f8ba1a81c81eb6c358d044f8577e63c3ccca8dc397fdaf072dd269103c0e940a758cd0f3ba7a49fc5e05cb
EBUILD pylast-5.3.0.ebuild 637 BLAKE2B 7423ce749fa120f7bde6976449612c245d747ffef0e557ecb2f666d1439882d00f873df4732819150145efc57309699980591d76d53ef8ba066375d2eda9665c SHA512 03548d61e245ca02ed0f05f776f26c55bb1db59b0406bca470e3aea0b0e37dc3fb78722c8b37de4e01ac88ce253238913b605ee24475413e07ad2fab27d00a39
+EBUILD pylast-5.4.0.ebuild 644 BLAKE2B beaa6eb4dc0555f09ee185c1f301e9f0832ae0b85862c2bf9ee3c09c5ca8a3d059aca352b8d79753f91178deb277e5c23e1896df63bc61c4ff493f1210e6f990 SHA512 0e5668bc6c1550bd12ecae934b31cc5130ae03e5608da9b161ac39836bae076cea8f0f944bdc91369f8130aeaad69672e5886357eb7b133e76aac4f31d5ba0f8
MISC metadata.xml 907 BLAKE2B a4a6aee5b2e805d27d001b7c51dfb2a26b935c38380e85027059b02e75057fc02f9ad311fd21326f6f16e7528a15c0577aae31f695f8a74ac42d274c10e7ca17 SHA512 1d0b7327a4e9a24940cff7a27b64bf5a27d5e2a1391d31a99d3473fccd54e534722ba826a64bcfc5f0da7a505241e617d23aa1f7490218f1d39af4cd3aa29357
diff --git a/dev-python/pylast/pylast-5.4.0.ebuild b/dev-python/pylast/pylast-5.4.0.ebuild
new file mode 100644
index 000000000000..de912eba2dc9
--- /dev/null
+++ b/dev-python/pylast/pylast-5.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest