summaryrefslogtreecommitdiff
path: root/dev-python/pylast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
commitaa4954f71a3ba2293395a8cce2321a70c39c7554 (patch)
tree35665855d8a569dca2bdf52a7316e2503df68208 /dev-python/pylast
parentb3b92de25c3fc5f6bddc5e513027140591a0b2a5 (diff)
gentoo auto-resync : 24:05:2024 - 00:07:11
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest2
-rw-r--r--dev-python/pylast/pylast-5.3.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 26675378c0ef..0fe8cc6cd75c 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,3 +1,5 @@
DIST pylast-5.2.0.tar.gz 41137 BLAKE2B a7742bd2a23e281ab1a12d0198c74f1b5d8302700cb58490a5b3bff693098c8c3bf548ed52ca7f8cefecbcc10972c57da9ca04fe1d791141aacbb84ead9592ed SHA512 1ae76ff4ec6f009388abfcf8525f1c19e47cbabaace1f5e8c518819d0856168d855b789e3c08a9699dd7ab88ebfc7c3ab81c2d74a0fa1fd210450741b99da8c6
+DIST pylast-5.3.0.tar.gz 41552 BLAKE2B 0d6fd60e02f6106cbbfe2027614d8d403c54ee1f749ea697dba7d863e7a1fc647f95d2ea341e1d0ecfa2900a1ae117920466bb8f8a0728c5a9dea6be8d1009f0 SHA512 b8d015d9d1452a650a6fc05019a145c2c5104c1acd0e296d7a9b536fd91710b4efe3dab2646b4b373ca13278fbdc385a64472829dfd1cf8980a22a5f2314afe9
EBUILD pylast-5.2.0.ebuild 643 BLAKE2B 45cd7b53523dca58f182280411e63942ac4452c517da6b898f9e4ef33bf07da0474bd8695f0ac4ec28f969f8d297d2660ab889749eabb4e6746b50a22374d61d SHA512 3c7693d00897bb7e374942159fdaf6973428ce7159ba671821cc1b0958fb6e42bb2159667c96692f81b44959317128af1f9eb880648862ec1b3d70a655e8da42
+EBUILD pylast-5.3.0.ebuild 650 BLAKE2B df7ab253631e32acd1757c444065c0c074dcddaeeac33b355bea2d3e21220da9c504efb6aeefab393a3d05ba388978be73afdfd59c9f38644cf7b34bc03f24c4 SHA512 dfde172954d37d43b4e6c57afe9148711908356fddb1842988e232b3072e7795256802623c351258fa6843ceed20c643c5cc43ff3bc21d4ff18147ba1bcf4b34
MISC metadata.xml 907 BLAKE2B a4a6aee5b2e805d27d001b7c51dfb2a26b935c38380e85027059b02e75057fc02f9ad311fd21326f6f16e7528a15c0577aae31f695f8a74ac42d274c10e7ca17 SHA512 1d0b7327a4e9a24940cff7a27b64bf5a27d5e2a1391d31a99d3473fccd54e534722ba826a64bcfc5f0da7a505241e617d23aa1f7490218f1d39af4cd3aa29357
diff --git a/dev-python/pylast/pylast-5.3.0.ebuild b/dev-python/pylast/pylast-5.3.0.ebuild
new file mode 100644
index 000000000000..d4308e6d07b6
--- /dev/null
+++ b/dev-python/pylast/pylast-5.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest