summaryrefslogtreecommitdiff
path: root/dev-python/pylast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pylast
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest2
-rw-r--r--dev-python/pylast/pylast-4.5.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index db71e03ae1c6..752172ec6af7 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,3 +1,5 @@
DIST pylast-4.4.0.tar.gz 39793 BLAKE2B 13a2bd4652b0dee142442f8bc6bf922f544b093be207efe8661f5355e37ff59a5c0d9c844193d2d3e4f22ccafc10993b8cced6872d4f0fece42c37524bee8beb SHA512 341b3f8a6691699b9581769d1f06908df8ec694a22d8918e4ed37af1f47287577c5fc156f3807c744aa9774d69e23570036f06a8e9921f3c7c7d21b53b8eb041
+DIST pylast-4.5.0.tar.gz 40175 BLAKE2B 394a6329d0c7f03ae70cf7ee5e19e310d4fc4b70f86a6e8ed66ad93674465433ff7ab06cfbfa82fd33302a6d85b9fe582402c2166746e7853d1bada9de5f2449 SHA512 c885f0ea415c2a6b96454abdbcef0b61732a5253ddff45a03d85a2b7d733f6bff47d1806576e4acc6d07763e404985e5c35341e37b88d586d1cbec811d984551
EBUILD pylast-4.4.0.ebuild 660 BLAKE2B 2107847cdb218c5a64e172044b9511ac2b79ee999ae344822b792e17ef209595cb3b161e327fda889f2be7550ffdd8eebbc9e4773a32264fb1becd031525c373 SHA512 e9e71e4fd3bd1e626c9c422d5f8c32ddbaeeb20c24807fae439939023cf910d28596e4944459cb6e0f54b56f10fb44cc2caa4da35aa888dfec5fe6e23051d239
+EBUILD pylast-4.5.0.ebuild 689 BLAKE2B 631b3e83941f19d1fe254806dd591e73476355d92c5f38962d40461998413e24da38ddf88a23ebf1d3b6ab454a615e00688838f3a454877eb944ddb424bd8fec SHA512 410ca6a8b9e2a8036b8fa64cf7d668b50130fc9d4a2d2dc8c49f49de56167c17c2a1610a34f38ddecd6080a906cd1d03865f175877ad2594c5c6f89889596a41
MISC metadata.xml 907 BLAKE2B a4a6aee5b2e805d27d001b7c51dfb2a26b935c38380e85027059b02e75057fc02f9ad311fd21326f6f16e7528a15c0577aae31f695f8a74ac42d274c10e7ca17 SHA512 1d0b7327a4e9a24940cff7a27b64bf5a27d5e2a1391d31a99d3473fccd54e534722ba826a64bcfc5f0da7a505241e617d23aa1f7490218f1d39af4cd3aa29357
diff --git a/dev-python/pylast/pylast-4.5.0.ebuild b/dev-python/pylast/pylast-4.5.0.ebuild
new file mode 100644
index 000000000000..803e6fc359f0
--- /dev/null
+++ b/dev-python/pylast/pylast-4.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}