summaryrefslogtreecommitdiff
path: root/dev-python/pyliblzma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyliblzma
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyliblzma')
-rw-r--r--dev-python/pyliblzma/Manifest3
-rw-r--r--dev-python/pyliblzma/metadata.xml12
-rw-r--r--dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyliblzma/Manifest b/dev-python/pyliblzma/Manifest
new file mode 100644
index 000000000000..e8516c537e06
--- /dev/null
+++ b/dev-python/pyliblzma/Manifest
@@ -0,0 +1,3 @@
+DIST pyliblzma-0.5.3.tar.bz2 43498 BLAKE2B ab58a052195b36fd3862281049b8825f085111db2315b7ee29320cc201a29effca8f21d15f1c8b805ff0ecffad78d120314f5030bf7d93f2cc63c58d369dfcc2 SHA512 272983aac426e86d6d636ccba4fe78a07d7282560081df937114162bfd317bd8023814693b8d473d0f7884e38a968ebeaf8f954a5a27c1f7e5da084f3fd05c65
+EBUILD pyliblzma-0.5.3-r1.ebuild 576 BLAKE2B df4ec421d4df50fa6db5ce3877cba886b1af8c49ea4d5b4fbe74d90e70a05d70dd6ece9e13e8cca8bf6891e51ce899de16b4b7fad63e05c8a02a3763ed133b6d SHA512 9291d6cb48ade4132e4d40b9643dbbc66d727e07b55ea5b11ce77d41a104b8595c44f5bce42938178a2e2621e92ce40aa56a618ebf3c8c97a595d79bbf8b4880
+MISC metadata.xml 364 BLAKE2B e4a68c4e875f4b2a0e9526e09b0a07d5babbf55a5dd6b972db3135a4615787fd3d96d4dbe689394431e8171179f2d9554f590c2f1f4f1907a3d2a4e6d85a1909 SHA512 9052e6e7da1cda1cf31028b8e8cb84c2fffab93505de75105d8cbe52a862c7f95929a9fc094da7692cf9deff1abeed4496abdbb057b9a6de24e64441648280f5
diff --git a/dev-python/pyliblzma/metadata.xml b/dev-python/pyliblzma/metadata.xml
new file mode 100644
index 000000000000..483419253126
--- /dev/null
+++ b/dev-python/pyliblzma/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyliblzma</remote-id>
+ <remote-id type="launchpad">pyliblzma</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild b/dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..f03093264c84
--- /dev/null
+++ b/dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for liblzma"
+HOMEPAGE="https://launchpad.net/pyliblzma https://pypi.org/project/pyliblzma/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-arch/xz-utils"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS="THANKS"
+
+python_test() {
+ esetup.py test
+}