summaryrefslogtreecommitdiff
path: root/dev-python/pylint-venv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
commitbd35a61d88b111f25f4b10126e0d4755545fc7a5 (patch)
tree656ac661ed7b28ad66ba778b74bc5fe4e2b86b10 /dev-python/pylint-venv
parent5d4291ee2ba8b85e8515b5f47b814a5c872eed04 (diff)
gentoo auto-resync : 29:10:2024 - 03:04:53
Diffstat (limited to 'dev-python/pylint-venv')
-rw-r--r--dev-python/pylint-venv/Manifest2
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.4.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/Manifest b/dev-python/pylint-venv/Manifest
index 9e9538c17e83..dc8b28623c5a 100644
--- a/dev-python/pylint-venv/Manifest
+++ b/dev-python/pylint-venv/Manifest
@@ -1,3 +1,5 @@
DIST pylint-venv-3.0.3.gh.tar.gz 15432 BLAKE2B 2a0315967aa7ac9628a7633360249d3bf5904d2e9939fe1c962ad7066694fd5b073df71e89f0ff4a6c278c3ccf6b41cd70c0b2928b58bbaa19a7910f18f7b697 SHA512 83632d7063f8e14bcf9213a059e8e6e20222518e5cc3d19a7cc3761e11ece2aaea9b2e648f0cacdb37e6995fd85371920ed8bcc7a28545c571d12da8e8b3d795
+DIST pylint-venv-3.0.4.gh.tar.gz 16790 BLAKE2B 3b85537d53844900f109bc3fee3cbd62ae958785df8a14f23e5fd4be181aa7b207c207daf87fd3bd7f18378e3a19a8e7586b783bb68dc656e630614ba8f59232 SHA512 e30e7dd0c90280c51f0ff5795a769a8cb45f177274d110c46642af0b68216d539441d36eed55046e0f426cf3c7c8878699c0750913e78b78d07b6dbfd7defe02
EBUILD pylint-venv-3.0.3.ebuild 931 BLAKE2B 092202e84cf221e729e14626574fccc5f823b89e2086e0cf3d6d1580e03d44ed32b952e8b2ab2caa4d2da790738aa334a3c99d08c46512809475d1f045bb95cc SHA512 e12180264b2017dfc5761024693db21d3cf18f4ea8cc8e23f7b22afdb3fdfb6a405560d024f86642193954e42792eb79e3f3a01ccb209ff3e0c71eaadb4b31bb
+EBUILD pylint-venv-3.0.4.ebuild 931 BLAKE2B 011e3226ea75793497b3841d0f815bb58fc5f04687681b85d251bef5e68c3ae12d917a47c4626cf5722e5b3d3a5e49fe5d60ea1518f72189694bc588604d527c SHA512 79909218adfe597641882b33741a7cafb0f2c15cc2edf80a0f57b88ad24ef9123fed09cdc0ca4a954d55de000d87e8f39457fb0b22637bea064e155a5adffcb0
MISC metadata.xml 412 BLAKE2B 8dc1e28ad5e2b21a9483906e776a96d598e294fbc4dbf669ecea9357055b1a7439e0046353ab39b3c2bfaab7924f43a89c309db735e44a00838dd1bed2f5c088 SHA512 4e7963aa4cdcc168bd4755f21cb58cb084c185e1c71ef9fdfe168feb1ec65fc4848c99801e449f253e420b9e34d49aab396d2e02bb60a7cbd3733dd2a899c6cd
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.4.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.4.ebuild
new file mode 100644
index 000000000000..1564a29b3717
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-3.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # we need to set PYTHONPATH explicitly since the test runs installed
+ # pylint (i.e. starts outside the test venv)
+ local -x PYTHONPATH=${S}:${PYTHONPATH}
+ bash test/test.sh || die "Test failed with ${EPYTHON}"
+}