summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-26 01:25:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-26 01:25:46 +0100
commit21dea977c89ba487b57c7856a4924950e667f209 (patch)
treeea817bd899b4d1759c030d6439f307b28e51588d /dev-python/pylint
parentc25088d4fc442a7d6dc3a8d0498b43024888318d (diff)
gentoo auto-resync : 26:09:2024 - 01:25:46
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-3.3.1.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 1b63cf547099..b9babd436f0a 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,7 @@
DIST pylint-3.2.7.gh.tar.gz 1448329 BLAKE2B 4ec4a0e2a886e7acc4694582e7f7902b6806750a12286986533a4e57c68eeac96bec43bb4cef2de6ec0a7811cde5ec2cc03226b2213d1b2107aafe73db03c32d SHA512 66dbf0f05aa7aac59f43cab6a1f23c29a3a37d9a19f2c54af0e0aa6f2630fc74d7602a6b6a250e1e02a24723d0513c54a7ee704026af16c8acc50b843708fd98
DIST pylint-3.3.0.gh.tar.gz 1453518 BLAKE2B 407ab1a3db4ae832c8ab7f26c3d3cd02c686305050f0dbd1168fe00e2e267aa169a99eb7e9a3a858a5ad58752a1e8a193692224c39971da93374da72a3d66ea7 SHA512 52bfc54691e5ea323032909c6e2bd8f265c70cc4941cb51ce4eb25e86ebfb22c54fdd9c92a8b5c518cbbcbb48894a9ae7bf2dcd6c2993533acb21ff3f9786f02
+DIST pylint-3.3.1.gh.tar.gz 1453572 BLAKE2B e756d72c0757a8d90491fddaa5a60cccedde043b4dbaf9162ccabd920bbb864bf109f619483474748a606dedb4bf889a57edb447ef77a40c7ee35e2019caf277 SHA512 86cb0019f53477346de44a7cf22b6ee6ec791d2cfc23ec0c1ffcc749752d52f255aa5dcfaaf7b124706ce8a87013d5e592c0896c527e10b8df06c974f440d3c6
EBUILD pylint-3.2.7.ebuild 2466 BLAKE2B f4fe7a099c040cdade243651084839039420bae8600b7f053797225fe8f18b8682051b40e4128f7a369f2ca1d4454fbcdeaff22a57f6584c150b1582716d98fd SHA512 a95a371e24b4d427fb02f334ddbaf2e0f7989850db2b82aed0d7f41e9dfa0a7a05742355ff3c0867f14b26214e86d588b9fdce03b0c3d65333e08381039a19ca
EBUILD pylint-3.3.0.ebuild 2416 BLAKE2B ba8e36d32f7f8621eda16968fc1605a8c9be34130fd9b3062f4b20d48a5f823ed1e13f9a71a837a1451560b397ea29a2d1b937cfbe9dffc488802740aeefdd2c SHA512 7b3750a442b961340d04f3e2f1d94c16cfd9e270038ee945b0aaed49363229c933ead500ba57ac9bcd15ac061f623eb8bb3795fba0e9d7a484168b40c9de465d
+EBUILD pylint-3.3.1.ebuild 2416 BLAKE2B 9ceae542e18562dc416a300e6e32047243cf7ecab61b0787896ee3dc723bf3200b49c4594240877d66d4aaff8c35b5a7f5bf8b972b717d884ff40c6f96140fd1 SHA512 a1edf00835122dc0a1282251da1bf478abb5fb412a917030f1833292505e08c7c2c9a6a824de849b1469909960b543f9da433b174f3202e41d7561c0310204f9
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.3.1.ebuild b/dev-python/pylint/pylint-3.3.1.ebuild
new file mode 100644
index 000000000000..78ddf6bce504
--- /dev/null
+++ b/dev-python/pylint/pylint-3.3.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-3.4[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.3.4[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
+ >=dev-python/pytest-8.3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.12[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ 'tests/test_functional.py::test_functional[use_yield_from]'
+ 'tests/test_functional.py::test_functional[wrong_import_order]'
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+
+ if ! has_version "dev-python/GitPython[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
+ rm -rf pylint || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}