summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
commit8e95bde8579d855189ccca3e693b4e3792f136c2 (patch)
tree4202dc7a3017eba106e5c5c5a41bcb3d08281143 /dev-python/pylint
parent25e5a6599437664a3eff8d9f8a966adc896e09e8 (diff)
gentoo auto-resync : 11:12:2023 - 23:23:25
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-3.0.3.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 7c7fe79b2ac2..6ba1abef1d94 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,5 @@
DIST pylint-3.0.2.gh.tar.gz 1420866 BLAKE2B 2679810940ee5b4a4dcde5a4a3d70052901d6ca8dfd025708fdfe3fadffc7713d3507eaea9a67a2fc0748478e8b6e2c2e66e487bf93749fcd9fea7d070197b16 SHA512 923fab3681aa266aa633cc122cd2076dc73588191ed116da0e83d9d0cff253c93634dd420d32b5ea780c25a8e9ff526d8393d4eae2e046a2ff82df3f5f9322a4
+DIST pylint-3.0.3.gh.tar.gz 1422200 BLAKE2B 999afa1a26cc9fdc8f88bc7a1173c4621f608321b09798de7dd30ef3f5fa295b354ae17acf52009dc340a527f2414f350777ea5893a522f44a31baa466242c63 SHA512 ac5fe236bab08cdacdf9fb78cbf444348bfaa4a359dabd17bfdef5d8a7d9b72a794fd5e7483ea326d1c006668fbd6c37d0aa1f8e7c9963bc75265eb9ced6d43b
EBUILD pylint-3.0.2.ebuild 2396 BLAKE2B c986caa5a26385d265a5a3ebb152b7f3a6570c39f61cddd39acf0ee2acf18c8246b6d66799e809151ccd7eaf819d0d48bb159ee176aa35348d3d7c39bc1ec726 SHA512 bea3b36f79cead5e51b251503c5c28e70abf686be72d18605fe473e81532c8c23bbc8b9bac792f6641dfd516c77b52b851fd9f59a3b2a0c9b02ff9974685a0e4
+EBUILD pylint-3.0.3.ebuild 2404 BLAKE2B 7978653f41417960a01cd845cbf12a4a7e795354f9e509e896e9b7b7a380c2c1c452e803138896e7a65e0027de3f502ae5a3fcc061759f3ca31f97b93a383eb0 SHA512 42daf9436e7bdf090aaa36ee15794e199f8a036af1b034e324b0bee9c53214e033042853d3b14fad550ccdf698854e904a3e65fa792cf176c44d711f16411d26
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.0.3.ebuild b/dev-python/pylint/pylint-3.0.3.ebuild
new file mode 100644
index 000000000000..0bdc5b7ba65f
--- /dev/null
+++ b/dev-python/pylint/pylint-3.0.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-3.1[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+
+ # incompatible versions of numpy/scikit-learn?
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # Requires GitPython
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
+ rm -rf pylint || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}