summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 19:38:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 19:38:57 +0100
commitc650f7cf611feaa59620fd8626e78108fa3b5e51 (patch)
tree31eba3ef4db85c7cef7cfb89ee87c81e732928a9 /dev-python/pylint
parent59970d0b9cd0a564851f255aebb29a9f76e39c19 (diff)
gentoo auto-resync : 11:10:2022 - 19:38:57
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-2.15.4.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 6ad9b438dd1d..8d4d6b1f1108 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,5 @@
DIST pylint-2.15.3.gh.tar.gz 1310617 BLAKE2B c060178b83b76d5d12d7afe702ba34684c84314cb17ce03e5549eb4e5cf3cd11df86f0c6cd3823b88464ccef23cd2d1d68e50fb813a2a2664f9b43ef0f872425 SHA512 7cc499a718924d936964f644d27674df16a342ea6cd4228a6c0b5eeccf468211290eed34df1614f99c63801b7d7713dcaffe09cae01e4ee9869e11d5dc63ec2a
+DIST pylint-2.15.4.gh.tar.gz 1312017 BLAKE2B 49be7a9288fc4186679946769fd9e88c6df504c1683ba0c070721c9223c4169c65bd0cf6344d755f30c440e5c7af98008457a8d7e6cd3d33952f083acb3f0641 SHA512 63cd8abb176092a2d43f38b6cdae5f8ec73a69e7267b6b1deb17150818d19f95be7ca07d5d75f02a9e238c60b153de5cc9294e5f93b8a5351ce0c99e9cf48216
EBUILD pylint-2.15.3.ebuild 2300 BLAKE2B dff27aca2f0dd150541a4dc9fc21203aef23cbc02546a6912c48ca1d92fbdee5fd03f48a0e748c75c7d8d2fd20f58a5f558e762def70ddaab2d9bd9eeaa13b98 SHA512 7e0828ec8dc4cdec698f6fda0b7ec29f32926120b0c5398a72bb93e35999df3e6c5e267adb0facaf592d169ea76f8bbd6b65525d731d475655983a0f468b1604
+EBUILD pylint-2.15.4.ebuild 2309 BLAKE2B f32c4ebb64f563e73be34d0a2d45da2eb1cfe6ca0e6947b462bcbe33761fbd82b1e73541b658e692e77f46273e61d6b6fa44658ea451fedbc269f521902760f5 SHA512 46e6260defab8a2649461f436f5e2179539cba2f59eb9aa46dd5689a3b2a3a1a6412b86a09cd39abe8a06e9388bbcc18bf8294e9c75f3385e4d6a7e2be8c152d
MISC metadata.xml 1100 BLAKE2B 97ec6bd2f6cf487afb93136e9ee58d0d5f8ad37e2ded456ed4f196e73fd37cddead2462d3592b44ca1a6c3722b1f194905238299f0c066945d1e22bdb18acc9b SHA512 0418d987879446fd76fe9b7fc4ee8b1c3c0d9bbab1d1fc3eb66eada0bc52f6b6480cf9852dc3a18b1915d2093642b9c87f24207e89b34d3e48c29a282a3ba979
diff --git a/dev-python/pylint/pylint-2.15.4.ebuild b/dev-python/pylint/pylint-2.15.4.ebuild
new file mode 100644
index 000000000000..77d9ff7407e1
--- /dev/null
+++ b/dev-python/pylint/pylint-2.15.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.14[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.12.11[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}