summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-29 08:00:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-29 08:00:25 +0100
commitd855918b46ba8714cf1320fe63b55fd0ed1748a6 (patch)
tree4d7d0e86122a07796a660310d507f93e1b7747b9 /dev-python/pylint
parentb8325835c82367d22428eb41afa0f2d375338d3c (diff)
gentoo auto-resync : 29:06:2024 - 08:00:25
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-3.2.5.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 29a0d9f43db5..667d40698b1c 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,7 @@
DIST pylint-3.2.3.gh.tar.gz 1444655 BLAKE2B 4d43c107b03cac4e1c054cac97e2082f1adcf8196fe9b6eabf7b582f0c226f7996526326d2cca19c4935c84bd11b0421f5c4b29022a2dd7f601a5b380f4eb4e8 SHA512 07492e98e709b4db0168479544a9ab79cde2bd2ef4c48a479192ae1241f2a96f21d90a83c697f2b43cb7a070fff3bdd77157ffe5cb746df8cc4277f391e27121
DIST pylint-3.2.4.gh.tar.gz 1446144 BLAKE2B 3b7d8560701b96af8b75ec00d7412f30fbd32a8122b510172f8990c44ad8a9ed03312c3d42d10d6433c47968441f5405a154c6cf4d7a33ad96f73be3820ef31a SHA512 84f5c31d5b67161e615c1b6664e068cd29a35da8d2ad54158d387a5fc61f6544a670413d828a4094c50e935df8c1ec1209124c45ca6b08d76f01f70615aa5610
+DIST pylint-3.2.5.gh.tar.gz 1446535 BLAKE2B fdc88c7873868b1cb689158d014c51a14be9200715ad2f870cc7f8703e1e29881d04092c5e49fd043d54b31258b25d0c0f40cb81cd50c0603835a67197b29d85 SHA512 bba78776ae2610456ecfecffd9571712c13c38006de19d569aaf11bdeee978e1ad33b09ce64288fb2ebccd76d76a788a8db39209cf3f9963d8a38a43605bcbaa
EBUILD pylint-3.2.3.ebuild 2472 BLAKE2B d777e357935bbb5100e5ca1a5d84b9292ecad6991414717cb5e8de348d2316d6a16c4d524bf10808cf0ba4a497970ef747367e473cfb82f71d060b10aebfc2b0 SHA512 e3a518d99d77b327cf785f1ab2bc8f6683bda2935c6c5e4493f624354fde276448c16b2baaedda93d509619f0d832db76ccb19360b8d413c3e0e1a359347a642
EBUILD pylint-3.2.4.ebuild 2480 BLAKE2B 0e475a0778874bee9c6ad5571a30c0ad702365a0bfe148b4dc07acb73f5e79a7aa074d0bb1339cdd57faec332ffb3ff15ad41e87989bca5ad7fcafde9413313a SHA512 3c83609e60c1b07d49c8e75be8e158636df695ce19345be7f282cfaadcb13557473c592b9e73e538b6af9294ae622f3fb59369a58b16dd0817ea225630f7be6d
+EBUILD pylint-3.2.5.ebuild 2480 BLAKE2B 0e475a0778874bee9c6ad5571a30c0ad702365a0bfe148b4dc07acb73f5e79a7aa074d0bb1339cdd57faec332ffb3ff15ad41e87989bca5ad7fcafde9413313a SHA512 3c83609e60c1b07d49c8e75be8e158636df695ce19345be7f282cfaadcb13557473c592b9e73e538b6af9294ae622f3fb59369a58b16dd0817ea225630f7be6d
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.2.5.ebuild b/dev-python/pylint/pylint-3.2.5.ebuild
new file mode 100644
index 000000000000..0a91ce1ceb1a
--- /dev/null
+++ b/dev-python/pylint/pylint-3.2.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-3.3[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.2.2[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[recursion_error_3159]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ 'tests/test_functional.py::test_functional[use_yield_from]'
+ 'tests/test_functional.py::test_functional[wrong_import_order]'
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+
+ if ! has_version "dev-python/GitPython[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
+ rm -rf pylint || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}