summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-12 06:41:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-12 06:41:42 +0000
commitdc9bfd846ffa3990be92029481684342bc57218e (patch)
treee540fa073e926609e919a6c6dcfb653d000d27cb /dev-python/pylint
parentf1634517e73f2faf342a366354c3e0f2edb45952 (diff)
gentoo auto-resync : 12:01:2025 - 06:41:42
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest4
-rw-r--r--dev-python/pylint/pylint-3.3.2.ebuild92
-rw-r--r--dev-python/pylint/pylint-3.3.3.ebuild4
3 files changed, 3 insertions, 97 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 8a36347e24ce..2a1bd54297ea 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pylint-3.3.2.gh.tar.gz 1454335 BLAKE2B dba68aead7d2babe885d4a94220e61ddc6c5759bd9703d2bbeb1c7d1c68b6bebce7cbe6d7b0cc18a7c8cfe32b7e0cc6be929e021e7a9223ae31839185c07558f SHA512 48f57bc74a47c8658cad9ede6bb8540077c72fc6b3e8d9d401ddd1d43daaf547637ad253af885ac503a79aa31c30de1b4b302c4d4001a18b68e064e505975980
DIST pylint-3.3.3.gh.tar.gz 1454469 BLAKE2B e44ee31359421c560f89eee04215c222ce6b9f1fdce97750fe118cdb011f69c2a44a0a5a870787f4cd0c647650a78bc5a01dc327d8aaa8976f89e298f26596a1 SHA512 2267e7684b464255d03366bfd7988ac74222c08903a8b93bd5bc64181b12d1386c56ebb6dd79eb5b3f6c1a71bbc60282bf388fafc37a3e2c271286bc07ff2ac7
-EBUILD pylint-3.3.2.ebuild 2408 BLAKE2B 2fd36a744eda25c399697c1d5c4668da583f0a32141707a126655405ef175689f3780c9ea9f8dab0841ad8d3f253d48ed55273214abff8c17f257cb7d3f35379 SHA512 e36dad4f1ab76f98b39b2a8a8c004f9e004f38b38c14c7392cea672b42e51038bab87ea77610c9c02ba2f2d8c4a789611cbb46c1f9ffb3569c66333d72a758b9
-EBUILD pylint-3.3.3.ebuild 2416 BLAKE2B d2d1742f2ce64ef6bb0d05d702132585ac493e4aba915993bf7c731dcbffcbe2e88cb8cb262cd884dbcd2c051c962dd7bd11de687e33420537d79011f2198692 SHA512 700ba71135ae05d16cc7bebb881fc9fa99ff764195b94d804d98c515550452cdced772532b8d7f75cd25cb9ff6eb2a87d5383143c4ff15aaa7be8f76a4a9516b
+EBUILD pylint-3.3.3.ebuild 2408 BLAKE2B b5d8f05f324776a1778b025488667b61b075a807c1e4f9654228679c288a0557e120d181032312e77eba285cebd9a4426752e793843b76cb2eb6b5bd56479c97 SHA512 c369d7088002e489a93ed6393c189f044b796aea8a80053ec577a0b5bbb8942cd96c1bf2ed572c27d8c7e3e2612ddca4713d12dacaa0f5d97b0b45010b2dbe0e
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.3.2.ebuild b/dev-python/pylint/pylint-3.3.2.ebuild
deleted file mode 100644
index a29067b0bba9..000000000000
--- a/dev-python/pylint/pylint-3.3.2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-3.4[${PYTHON_USEDEP}]
- >=dev-python/astroid-3.3.5[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/gitpython-3[${PYTHON_USEDEP}]
- ' 'python*' )
- >=dev-python/pytest-8.3[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.12[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- 'tests/test_functional.py::test_functional[use_yield_from]'
- 'tests/test_functional.py::test_functional[wrong_import_order]'
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
-
- if ! has_version "dev-python/gitpython[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/profile/test_profile_against_externals.py
- tests/testutils/_primer/test_package_to_lint.py
- tests/testutils/_primer/test_primer.py
- )
- fi
-
- rm -rf pylint || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pylint/pylint-3.3.3.ebuild b/dev-python/pylint/pylint-3.3.3.ebuild
index 7344911a46a3..4ebcea8d606b 100644
--- a/dev-python/pylint/pylint-3.3.3.ebuild
+++ b/dev-python/pylint/pylint-3.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
RDEPEND="