summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
commitf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (patch)
treedd0f7da0455831dffb2cb662e7dae760f92e68ad /dev-python/pylint
parent770d63f36dbe1722e0ff9ab55eeca49986f01527 (diff)
gentoo auto-resync : 16:02:2025 - 00:13:18
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest4
-rw-r--r--dev-python/pylint/pylint-3.3.3.ebuild92
-rw-r--r--dev-python/pylint/pylint-3.3.4.ebuild2
3 files changed, 2 insertions, 96 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index d32fdf111b6c..cfc28141eeed 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pylint-3.3.3.gh.tar.gz 1454469 BLAKE2B e44ee31359421c560f89eee04215c222ce6b9f1fdce97750fe118cdb011f69c2a44a0a5a870787f4cd0c647650a78bc5a01dc327d8aaa8976f89e298f26596a1 SHA512 2267e7684b464255d03366bfd7988ac74222c08903a8b93bd5bc64181b12d1386c56ebb6dd79eb5b3f6c1a71bbc60282bf388fafc37a3e2c271286bc07ff2ac7
DIST pylint-3.3.4.gh.tar.gz 1455691 BLAKE2B 294cedc1d0ff5cf907ed847958d3067d526d7709df0ca9db2885fbd292b73d08d6b36708b1309a995790045d1eb5c55fe6d73f2bedaa6698d7fbd131dd010479 SHA512 cd99d69e3689986177320369a0b738054f92b194ff4a3f469d006de92181db1c88a068a9955dafc4df297256740f212f608b6c4bb050d25d0dbeb4c6d5466d44
-EBUILD pylint-3.3.3.ebuild 2408 BLAKE2B b5d8f05f324776a1778b025488667b61b075a807c1e4f9654228679c288a0557e120d181032312e77eba285cebd9a4426752e793843b76cb2eb6b5bd56479c97 SHA512 c369d7088002e489a93ed6393c189f044b796aea8a80053ec577a0b5bbb8942cd96c1bf2ed572c27d8c7e3e2612ddca4713d12dacaa0f5d97b0b45010b2dbe0e
-EBUILD pylint-3.3.4.ebuild 2416 BLAKE2B 598833f3f17bd2a17d3766d6d17d7ebb1e6764998e2b0bb7ecdf2a1b11ced3a15e2f63f2040cd7a80ab9d4f0aabd6cb6ee19bf5c156c7d217d9593bc656b0675 SHA512 ca5a34ba5e8692af5f320e367cfc43dd2659978714056b14ef7f43e6d2b216c98b4f23f239c46081a806d350f370d43992cd5b57a61c001eed6d1f5b9d158340
+EBUILD pylint-3.3.4.ebuild 2408 BLAKE2B b0bbfc217652f9cc65a18d09f3508ecb78019c56a36f2ba7d5c6d6bce7bee38a89217ea2c2f617a377b013013c8baf6bca0e3e1ac35a7ee930aefe633fe1b9d7 SHA512 191fe7b92623b49a3064214133473e3e4908992ca58b070b1b5c496bf09dad4d1c1a2742c6bb1d3fef5d4f9f02edbd7cb19ad56653fbd116a8bdc34592818d45
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.3.3.ebuild b/dev-python/pylint/pylint-3.3.3.ebuild
deleted file mode 100644
index 4ebcea8d606b..000000000000
--- a/dev-python/pylint/pylint-3.3.3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-3.4[${PYTHON_USEDEP}]
- >=dev-python/astroid-3.3.8[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/gitpython-3[${PYTHON_USEDEP}]
- ' 'python*' )
- >=dev-python/pytest-8.3[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.12[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- 'tests/test_functional.py::test_functional[use_yield_from]'
- 'tests/test_functional.py::test_functional[wrong_import_order]'
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
-
- if ! has_version "dev-python/gitpython[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/profile/test_profile_against_externals.py
- tests/testutils/_primer/test_package_to_lint.py
- tests/testutils/_primer/test_primer.py
- )
- fi
-
- rm -rf pylint || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pylint/pylint-3.3.4.ebuild b/dev-python/pylint/pylint-3.3.4.ebuild
index 2bb8e0492755..9d3344df1096 100644
--- a/dev-python/pylint/pylint-3.3.4.ebuild
+++ b/dev-python/pylint/pylint-3.3.4.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
RDEPEND="