summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-13 18:47:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-13 18:47:08 +0000
commitf30563609870941d7e5078dc39cfa30a0e696058 (patch)
tree156e4ad08bce26a869f00c528bc2eb9fb88cb326 /dev-python/pylint
parent57fe9fa5a06dc3ef922443afcd67321b071455d4 (diff)
gentoo auto-resync : 13:03:2024 - 18:47:08
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest4
-rw-r--r--dev-python/pylint/pylint-3.0.4.ebuild95
-rw-r--r--dev-python/pylint/pylint-3.1.0.ebuild2
3 files changed, 2 insertions, 99 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index a54fa6414180..c7394e903b4d 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pylint-3.0.4.gh.tar.gz 1423538 BLAKE2B a7ca336831266202f32699b17785fc671222738bdefc2b03dba2a27dde81a193c7d4b51c09d6f6bd61bacaf743dade3ca681c396d64149e1ddd25a897da43952 SHA512 ad674c86a2d52e68e913a92e9e24195c7af185d551b225b6b12b604ca3d9c2e9e3570cff423577dfac66e7af17f48aee2b1807e3973d2e0abba566a85d11e112
DIST pylint-3.1.0.gh.tar.gz 1433040 BLAKE2B a224af608fa5ccb256c18073a70f82c399ad23ff6df65f7ae3504c67060f5ba1cd36022c7d53a42f0f93bd4648340433601d2f479bef41a4281e8041a9d15715 SHA512 bb7f09fa8b2c6f218c0e4d74ec2d7bbcb5e9d9fa8c2aeae5a1bf899f25080251609f284959fab14dd93cc5dd911688e25d3d4e1e030a1790578bc78ef1ce2bf7
-EBUILD pylint-3.0.4.ebuild 2437 BLAKE2B 8102c20a12cfe9d8ff626621b3514509460b2549c58996a75bfcad555548c85da145616bddcfc9eb0c2162b196143d4f80d7fb530d23b9b339760b6e7936c3a0 SHA512 a91b00d75aa5710cfb8703904a31b51085e055a8f7d75f8ac86995d3f873e1b847f2ecb09688c63074172f90c086d8d785bde61e854c9bcadc9a6e4a956c2413
-EBUILD pylint-3.1.0.ebuild 2412 BLAKE2B 3361c90daf68a35235146af13720936c28db7747e99d111ba6b99a6d3a1f6a4361c7bc43bff81e284848322fb9f5cac6b4d665fe761aedab5fbf2c3fcba7adf2 SHA512 6611fb782354f1f66fa1ac1bf8b6d85c7a12bdc30b5f4e5727e4b65fc16057a2f510686a9fcde44cf44668fc0a655dc370d86b354493a1ba9449f686b14346ca
+EBUILD pylint-3.1.0.ebuild 2404 BLAKE2B ab5dc8d7654e563fbc2076617093961785856b8dc116789fbb834038c0e1a4267a7e3e0be551dad0295858de3496c1d54fc2af0a82f3e3a66add64c46f4b6861 SHA512 deea08de8ad0bc81985df86eecc7be374399eb5aa58e2188e13573cc8908a25ebce9103de7e0be5ebff9836d21d87be3472104c840bc817e1286f9d02ca303bf
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.0.4.ebuild b/dev-python/pylint/pylint-3.0.4.ebuild
deleted file mode 100644
index 7e31ce7cc0b9..000000000000
--- a/dev-python/pylint/pylint-3.0.4.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
-# Adjust dep bounds!
-RDEPEND="
- <dev-python/astroid-3.1[${PYTHON_USEDEP}]
- >=dev-python/astroid-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
- ' 'python*' )
- <dev-python/pytest-8[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
-
- # incompatible versions of numpy/scikit-learn?
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
-
- if [[ ${EPYTHON} == pypy3 ]]; then
- # Requires GitPython
- EPYTEST_IGNORE+=(
- tests/profile/test_profile_against_externals.py
- tests/testutils/_primer/test_package_to_lint.py
- tests/testutils/_primer/test_primer.py
- )
- fi
-
- rm -rf pylint || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pylint/pylint-3.1.0.ebuild b/dev-python/pylint/pylint-3.1.0.ebuild
index f546e777fcd7..baeb1ca3ae1a 100644
--- a/dev-python/pylint/pylint-3.1.0.ebuild
+++ b/dev-python/pylint/pylint-3.1.0.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
RDEPEND="