summaryrefslogtreecommitdiff
path: root/dev-python/pylru/pylru-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pylru/pylru-1.2.0.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pylru/pylru-1.2.0.ebuild')
-rw-r--r--dev-python/pylru/pylru-1.2.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/pylru/pylru-1.2.0.ebuild b/dev-python/pylru/pylru-1.2.0.ebuild
index 73f3e86bb7fa..f22b1b0e9eb6 100644
--- a/dev-python/pylru/pylru-1.2.0.ebuild
+++ b/dev-python/pylru/pylru-1.2.0.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="A least recently used (LRU) cache for Python"
HOMEPAGE="https://github.com/jlhutch/pylru"
-LICENSE="GPL-2"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64"
-BDEPEND=""
-RDEPEND=""
+python_test() {
+ "${EPYTHON}" test.py || die "tests failed under ${EPYTHON}"
+}