summaryrefslogtreecommitdiff
path: root/dev-python/pymacaroons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/pymacaroons
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/pymacaroons')
-rw-r--r--dev-python/pymacaroons/Manifest3
-rw-r--r--dev-python/pymacaroons/metadata.xml16
-rw-r--r--dev-python/pymacaroons/pymacaroons-0.13.0.ebuild29
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pymacaroons/Manifest b/dev-python/pymacaroons/Manifest
new file mode 100644
index 000000000000..125d053761d4
--- /dev/null
+++ b/dev-python/pymacaroons/Manifest
@@ -0,0 +1,3 @@
+DIST pymacaroons-0.13.0.gh.tar.gz 25607 BLAKE2B ff21e88842c54f7ce84e8b3ad59d42ee43f2bb2073ebbb7f47dee123086c1466024420246a4da2eae462bc36e44a3621b75144846e090073c5063b0af24f1ad1 SHA512 60da7e03d68083f8effdc06b338dd04dbd6a39ff137373721af09f1282fb035f969459d2ef80f4d728dcf95f6244b7b2de443e48658e0551462ab46daf3884a2
+EBUILD pymacaroons-0.13.0.ebuild 746 BLAKE2B d13403d01df6bfd5cc2b9fd08c04fb1460e5f8274e95d80653f9b3a1022bda3f8e364bbf2961c44cdc93b6f7c4207808779917349ddd7e53d1bf3d1b12d45edd SHA512 ac50305fd2324421eb9b525a2dcee7392d3329ec47a2e014a458d80130223d94749c39fa9f4fcc8933aaa320e13ed0dc76c40a741783b19b67543697c428e4e9
+MISC metadata.xml 525 BLAKE2B 5e4d390565834de4093dc6b579e1aef4fffd3a97b3d83aa038e0bbd4cb1e28acdcfc8bf5a49bd7a2988e79f1dc868c2c3ced235ba2e1917c0f37b915a25a1584 SHA512 bd4bbc4408659318126f279c33b9fd8335c8d9620014ce72594171b28b3ffb2cdb044cd67d560434c849a8baa1d1b21b0c9b16d8e47954b7ea64f170c9edbede
diff --git a/dev-python/pymacaroons/metadata.xml b/dev-python/pymacaroons/metadata.xml
new file mode 100644
index 000000000000..5126b7df482e
--- /dev/null
+++ b/dev-python/pymacaroons/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pymacaroons</remote-id>
+ <remote-id type="github">ecordell/pymacaroons</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild b/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
new file mode 100644
index 000000000000..24e60796d20c
--- /dev/null
+++ b/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyMacaroons is a Python implementation of Macaroons."
+HOMEPAGE="
+ https://github.com/ecordell/pymacaroons
+ https://pypi.org/project/pymacaroons/
+"
+SRC_URI="https://github.com/ecordell/pymacaroons/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests are incompatible with dev-python/hypothesis::gentoo. This package needs
+# <2.0.0, because needed hypothesis.specifiers module was removed in 2.0.0.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"