summaryrefslogtreecommitdiff
path: root/dev-python/pymad/pymad-0.11.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /dev-python/pymad/pymad-0.11.3.ebuild
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'dev-python/pymad/pymad-0.11.3.ebuild')
-rw-r--r--dev-python/pymad/pymad-0.11.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pymad/pymad-0.11.3.ebuild b/dev-python/pymad/pymad-0.11.3.ebuild
new file mode 100644
index 000000000000..c900abb0ebeb
--- /dev/null
+++ b/dev-python/pymad/pymad-0.11.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for libmad MP3 decoding in python"
+HOMEPAGE="
+ https://github.com/jaqx0r/pymad/
+ https://pypi.org/project/pymad/
+"
+SRC_URI="
+ https://github.com/jaqx0r/pymad/releases/download/v${PV}/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="media-libs/libmad"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest