summaryrefslogtreecommitdiff
path: root/dev-python/pymdown-extensions/pymdown-extensions-10.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-23 01:25:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-23 01:25:12 +0100
commitde59eb4554f5fe0d506a66bb96630a35f99c09f7 (patch)
tree93910196831fcf1967ee9af465900caa7d70fa5b /dev-python/pymdown-extensions/pymdown-extensions-10.10.ebuild
parent1802160f23e91c618b3c7379fd99127682cfce19 (diff)
gentoo auto-resync : 23:09:2024 - 01:25:12
Diffstat (limited to 'dev-python/pymdown-extensions/pymdown-extensions-10.10.ebuild')
-rw-r--r--dev-python/pymdown-extensions/pymdown-extensions-10.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pymdown-extensions/pymdown-extensions-10.10.ebuild b/dev-python/pymdown-extensions/pymdown-extensions-10.10.ebuild
new file mode 100644
index 000000000000..8447dcb9ba40
--- /dev/null
+++ b/dev-python/pymdown-extensions/pymdown-extensions-10.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions for Python Markdown"
+HOMEPAGE="
+ https://github.com/facelessuser/pymdown-extensions/
+ https://pypi.org/project/pymdown-extensions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pygments-2.12.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}