summaryrefslogtreecommitdiff
path: root/dev-python/pymdstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-python/pymdstat
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-python/pymdstat')
-rw-r--r--dev-python/pymdstat/Manifest4
-rw-r--r--dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild29
-rw-r--r--dev-python/pymdstat/pymdstat-0.4.2.ebuild29
3 files changed, 31 insertions, 31 deletions
diff --git a/dev-python/pymdstat/Manifest b/dev-python/pymdstat/Manifest
index 0b2045c38e65..fc91c8cea6e9 100644
--- a/dev-python/pymdstat/Manifest
+++ b/dev-python/pymdstat/Manifest
@@ -1,3 +1,3 @@
-DIST pymdstat-0.4.2.tar.gz 5010 BLAKE2B 4fe196916809513b063144ca4097676e2c826f38bccfdcb387aabd95d6b5d471eceec1a29fc5ffb41e7019e1570e2d805bbfa10f22ec7ececcb30afd7fc1a4ed SHA512 2e3c07d59151069962e1ba601b3751b331e233fdc6bbdeb0cada69ce36a731c12bcc6447218cc0c1ae4dd63d39d2be2bc3677aba739797cc534c5e38d1c72458
-EBUILD pymdstat-0.4.2.ebuild 597 BLAKE2B 1194d4d0af109a3b6ea64039ef3fc3f18261d9205150d77d6717a5936c94c3ba0368cccccf631b99ae914e65765d8fb2b58327e5afbbefa78d7860b53cb24c6a SHA512 0bf67e168fbbed21bf8fec932a2778c606442f44ad67089c560969c1008d57ef1d393cdb1fc36f51da8ab9621d1cf66b9af81355da128cd480dc6e9720d561ac
+DIST pymdstat-0.4.2-r1.tar.gz 14798 BLAKE2B 179c88a8999b4908586a3bc1698de9df25e94203b723b2981f9ac6e1b2ef47845c9e625c1daa40990dff7e90aece34fc471c3c5a0278a85c4c526d37574e5fed SHA512 7c9815b365fdb37ffe37c65d280a3bc4370f09fb8dad18ff9c68f61b8cc906e6b8d8e0fe0dd1570e68349f535f23cfb8afd52ba805d78e795d5c6f9730f7f2d0
+EBUILD pymdstat-0.4.2-r1.ebuild 765 BLAKE2B 633359c082777877708393f2f6e7fa7da6d2d952476fddebc4737e2e8c77415f4d5c0a0cc82bfbb5bcecf19640a87c6dc78dce5d4de230c5a1850ae4c32f6abd SHA512 0b7fa466f7786775ff781119910df1b6a8871cc4fa26c3deaaaddd29950baefe19660dbad5fcfa1c8d6f4b14570c81c77e796163e7f44767611afe3d3af5f97f
MISC metadata.xml 511 BLAKE2B 764b07013ad9a90442a60051d2cd17184b5058b24d1dfe08f0eac50102822e13cb38941e52b1f2a330682ab62d3b0f2983120b8985f0efc86e7dbc051d569f85 SHA512 54862557fb9d9ec32f94086ba8df5dfb5f4e4e804f1ea280157418b46ff9ecdedee8b3e333ec2643b8a09d54c769d010514789c3bc75fa28c75623b732a088ac
diff --git a/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild b/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..1ba2d042f2be
--- /dev/null
+++ b/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python library to parse Linux /proc/mdstat"
+HOMEPAGE="https://github.com/nicolargo/pymdstat
+ https://pypi.org/project/pymdstat/"
+
+# drop the ${PVR} if there is a version bump
+SRC_URI="https://github.com/nicolargo/${PN}/archive/v${PV}.tar.gz -> ${PN}-${PVR}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( 'AUTHORS' 'NEWS' 'README.rst' )
+
+python_prepare_all() {
+ sed -e '/data_files/ d' -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" unitest.py -v || die "testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/pymdstat/pymdstat-0.4.2.ebuild b/dev-python/pymdstat/pymdstat-0.4.2.ebuild
deleted file mode 100644
index aea52cd31c37..000000000000
--- a/dev-python/pymdstat/pymdstat-0.4.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to parse Linux /proc/mdstat"
-HOMEPAGE="https://github.com/nicolargo/pymdstat
- https://pypi.org/project/pymdstat/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# Not included
-RESTRICT=test
-
-python_test() {
- ${PYTHON} unitest.py || die
-}