summaryrefslogtreecommitdiff
path: root/dev-python/pymilter/pymilter-1.0.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 08:04:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 08:04:48 +0100
commitb46abba85084f65c8b5d619bfc4e2c5373ad4067 (patch)
tree605bf2723f935f10b93678a969b730394d570e2c /dev-python/pymilter/pymilter-1.0.4-r3.ebuild
parent00d9a8fc3e9e5bafeff6747e978c1685b384e587 (diff)
gentoo auto-resync : 04:08:2022 - 08:04:47
Diffstat (limited to 'dev-python/pymilter/pymilter-1.0.4-r3.ebuild')
-rw-r--r--dev-python/pymilter/pymilter-1.0.4-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pymilter/pymilter-1.0.4-r3.ebuild b/dev-python/pymilter/pymilter-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..268e99b48bdf
--- /dev/null
+++ b/dev-python/pymilter/pymilter-1.0.4-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to sendmail milter API"
+HOMEPAGE="https://github.com/sdgathman/pymilter"
+SRC_URI="https://github.com/sdgathman/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="mail-filter/libmilter:="
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests unittest