summaryrefslogtreecommitdiff
path: root/dev-python/pyml/pyml-0.7.13.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyml/pyml-0.7.13.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyml/pyml-0.7.13.3.ebuild')
-rw-r--r--dev-python/pyml/pyml-0.7.13.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyml/pyml-0.7.13.3.ebuild b/dev-python/pyml/pyml-0.7.13.3.ebuild
new file mode 100644
index 000000000000..04dbc22b1f09
--- /dev/null
+++ b/dev-python/pyml/pyml-0.7.13.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MYP=PyML-${PV}
+
+DESCRIPTION="Python machine learning package"
+HOMEPAGE="http://pyml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ pushd data > /dev/null
+ "${PYTHON}" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || die "tests failed"
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
+}