summaryrefslogtreecommitdiff
path: root/dev-python/pymoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pymoc
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pymoc')
-rw-r--r--dev-python/pymoc/Manifest3
-rw-r--r--dev-python/pymoc/metadata.xml32
-rw-r--r--dev-python/pymoc/pymoc-0.5.0.ebuild28
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pymoc/Manifest b/dev-python/pymoc/Manifest
new file mode 100644
index 000000000000..bb2cbddf2605
--- /dev/null
+++ b/dev-python/pymoc/Manifest
@@ -0,0 +1,3 @@
+DIST pymoc-0.5.0.tar.gz 33843 SHA256 08fd88df8c4013803c8c26b2183816e087c500e1d3b6172fed4d98a48269a8ba SHA512 cb327bed6fffa6eb4354c06f9b7e056baa9df1010d722b4fade6873fb862c4b27ea0a11647a510ce4007f7b8158e13eee7e146258d4c58ecee82adddf33bf89c WHIRLPOOL 17d56de5ddc63279d597f3a436a8f3a030cc696fb1495ce3cc9ee93c10a7a60aef1dcf77888514308c64945ec76ef7b38f11715606b512c80f3106b16897e0c1
+EBUILD pymoc-0.5.0.ebuild 688 SHA256 965904893940ae4e8477ab1a50aded26370435da77b94a6edd90623d0d840e9f SHA512 f1b6df1c84f858d7d701b79c1dea2f9f929cadb533b0eec1b4f79c9c8dd246b25f80d17200ccf171a004f7436d136ad8e9ae4998896732df01364370342893a4 WHIRLPOOL 8be8eddad9fb4ca7334916d0492b6d1fe2cc72550c92bd27d73cbb0b5644d308760391a8f6827c462ff8fe4095bf5c717dc5dfefd025fe201cf71a381dc24897
+MISC metadata.xml 1614 SHA256 834fcad4f12d4d075d528ae4f98b3883fb2fdf95c69c0f2e5b239fd1d2725a33 SHA512 5ea8168faa544523fe9f5ddc20e978ba09005fb94e6ac9ca5dbabb50c14fbd9bd3485e9a46960414cb791e9b761b8a9d88990dcbcbb78758b59a178f8ce96622 WHIRLPOOL 16cbfe3d0a4dcbb04ca874d674aa192b70f0bad9ac1e5e5faa2630ed3c0bc9d4e06bd2ab5ea2501b31ddca609641c653817c4aa68cbaed001025049f02850891
diff --git a/dev-python/pymoc/metadata.xml b/dev-python/pymoc/metadata.xml
new file mode 100644
index 000000000000..0539850fc0b0
--- /dev/null
+++ b/dev-python/pymoc/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Frequently astronomical survey catalogues or images are sparse and
+ cover only a small part of the sky. In a Multi-Order Coverage map
+ the extent of data in a particular dataset is cached as a
+ pre-calculated mask image. The hierarchical nature enables fast
+ boolean operations in image space, without needing to perform complex
+ geometrical calculations. Services such as VizieR generally offer the
+ MOC masks, allowing a faster experience in graphical applications
+ such as Aladin, or for researchers quickly needing to locate which
+ datasets may contain overlapping coverage.
+
+ The MOC mask image itself is tessellated and stored in NASA HealPix
+ format, encoded inside a FITS image container. Using the HealPix
+ (Hierarchical Equal Area isoLatitude Pixelization) tessellation
+ method ensures that more precision (pixels) in the mask are available
+ when describing complex shapes such as approximating survey or
+ polygon edges, while only needing to store a single big cell/pixel
+ when an coverage is either completely inside, or outside of the mask.
+ Catalogues can be rendered on the mask as circles.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pymoc</remote-id>
+ <remote-id type="github">grahambell/pymoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymoc/pymoc-0.5.0.ebuild b/dev-python/pymoc/pymoc-0.5.0.ebuild
new file mode 100644
index 000000000000..98bed1677f21
--- /dev/null
+++ b/dev-python/pymoc/pymoc-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Python Multi-Order Coverage maps for Virtual Observatory"
+HOMEPAGE="https://pymoc.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/healpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONPATH=lib "${PYTHON}" -m unittest discover -s test || die
+}