summaryrefslogtreecommitdiff
path: root/dev-python/pymoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pymoc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pymoc')
-rw-r--r--dev-python/pymoc/Manifest3
-rw-r--r--dev-python/pymoc/metadata.xml32
-rw-r--r--dev-python/pymoc/pymoc-0.5.0.ebuild28
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pymoc/Manifest b/dev-python/pymoc/Manifest
new file mode 100644
index 000000000000..70632a19a16c
--- /dev/null
+++ b/dev-python/pymoc/Manifest
@@ -0,0 +1,3 @@
+DIST pymoc-0.5.0.tar.gz 33843 BLAKE2B 928b32a2982fa6faafbed04476bc3af444ae0e8617bad323f21d89bac8c6a21a8b24d721fb0502a0d5034e1eeaa67972666508e3fc2ad210c44e9a1c291a192b SHA512 cb327bed6fffa6eb4354c06f9b7e056baa9df1010d722b4fade6873fb862c4b27ea0a11647a510ce4007f7b8158e13eee7e146258d4c58ecee82adddf33bf89c
+EBUILD pymoc-0.5.0.ebuild 688 BLAKE2B 54e80f3ca06e327e5ac66b1c376fb3f59b947b58f505d3032957d2bc63bdd32b3537cafc0f1fd3b32181345c844cc79422b0123e088a84f23223c4492d3b905c SHA512 f1b6df1c84f858d7d701b79c1dea2f9f929cadb533b0eec1b4f79c9c8dd246b25f80d17200ccf171a004f7436d136ad8e9ae4998896732df01364370342893a4
+MISC metadata.xml 1614 BLAKE2B 7cda82792a959395b3bc869efb67b836743b59412da5ad915c8752991a2fe116dd6c5ff5fdc26e7b53a590c95ecf677bb8994bef9484f91ce55a0b9a0a56de1a SHA512 5ea8168faa544523fe9f5ddc20e978ba09005fb94e6ac9ca5dbabb50c14fbd9bd3485e9a46960414cb791e9b761b8a9d88990dcbcbb78758b59a178f8ce96622
diff --git a/dev-python/pymoc/metadata.xml b/dev-python/pymoc/metadata.xml
new file mode 100644
index 000000000000..0539850fc0b0
--- /dev/null
+++ b/dev-python/pymoc/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Frequently astronomical survey catalogues or images are sparse and
+ cover only a small part of the sky. In a Multi-Order Coverage map
+ the extent of data in a particular dataset is cached as a
+ pre-calculated mask image. The hierarchical nature enables fast
+ boolean operations in image space, without needing to perform complex
+ geometrical calculations. Services such as VizieR generally offer the
+ MOC masks, allowing a faster experience in graphical applications
+ such as Aladin, or for researchers quickly needing to locate which
+ datasets may contain overlapping coverage.
+
+ The MOC mask image itself is tessellated and stored in NASA HealPix
+ format, encoded inside a FITS image container. Using the HealPix
+ (Hierarchical Equal Area isoLatitude Pixelization) tessellation
+ method ensures that more precision (pixels) in the mask are available
+ when describing complex shapes such as approximating survey or
+ polygon edges, while only needing to store a single big cell/pixel
+ when an coverage is either completely inside, or outside of the mask.
+ Catalogues can be rendered on the mask as circles.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pymoc</remote-id>
+ <remote-id type="github">grahambell/pymoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymoc/pymoc-0.5.0.ebuild b/dev-python/pymoc/pymoc-0.5.0.ebuild
new file mode 100644
index 000000000000..98bed1677f21
--- /dev/null
+++ b/dev-python/pymoc/pymoc-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Python Multi-Order Coverage maps for Virtual Observatory"
+HOMEPAGE="https://pymoc.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/healpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONPATH=lib "${PYTHON}" -m unittest discover -s test || die
+}