summaryrefslogtreecommitdiff
path: root/dev-python/pymongo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/pymongo
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest2
-rw-r--r--dev-python/pymongo/pymongo-3.12.1.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index 097618ac8420..4cc08d2f4985 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,5 +1,7 @@
DIST mongo-python-driver-3.11.4.tar.gz 983009 BLAKE2B b2ca8d90a34b41c0991b545626853137b6a7f5f006dbb5d7a93fd8312759b53b99415583ca5ba982abb420db8502cb9de745f1ac0962efa05eb05ecb4289c323 SHA512 ecd2ff41ab902423dc58901cd9a8355e200f5b00a4eea4a8e950de75674fd59f7367df1ab7ee6c09bf515b8fa110cac0f7de084fbe14527486a9c38a0c8c9c27
DIST mongo-python-driver-3.12.0.tar.gz 1062091 BLAKE2B 636a34a42d43a6ecd549c51e9e5b3a617291b64a1ba91d7473c365f8df88d59efd7b2906dd80147ffab4309d38cce30a3475bbe142e347312823236f8657c801 SHA512 fc2734b8821b42cca1b67930d5c7612526e51292144a376425627ea6254b09128ccd894af3be293184f940c7f8faa1c0cd3a0d069f9b4143a15cb32279c3bdb1
+DIST mongo-python-driver-3.12.1.tar.gz 1067667 BLAKE2B 3f18c5aa92ce180067f9c86e1fcbd80543274a2ee33ce1fad5741f0e7f5a9cb0520c33b8fe885ea69c2c8ce168747a44129fe79a5df389b83bd5e77a6ec4a687 SHA512 1fc98c33d8140ab045804130fc27b655a8622318f7030967d841e7a296dcdfb89a125cb2574a9b08eef15d3fdc089f268631501743b46d04a7b465cc45c0c04e
EBUILD pymongo-3.11.4.ebuild 2709 BLAKE2B 9c805d2fdb0427c015d0dca59c4d718c10e3799d8f00745d109566f9e6a6c9f68a0d63137bcd5e1ca756eb889bd5a4d0fd01d8ac182a3bcdee0e96ae3dbbed36 SHA512 4fb36123d4b2c50362386f7ceb545fd756433781c033565ba4881e8570b2c69f2eaf45f2c93da589776b5fce5da40a9489bae1768c569e9c626543db3d96b679
EBUILD pymongo-3.12.0.ebuild 2713 BLAKE2B 73c23556f161f9dcf0601026ef3f7d07b308d65e2c4c41aba631d0c6a7e21a11bc8789727f90b205eb0c1adce66ec5c883c740babd1affac4f99205bc9c9d4d4 SHA512 689f54b4e4db3c3d4ffa986d0a941201ad2948d1f9f9fb768706b88f01b979a35222cb75ef7edb84c0593f2222044635817791798cc0ad87a07e892cfc4f23c0
+EBUILD pymongo-3.12.1.ebuild 2713 BLAKE2B 42bba4278c4fd26d43861241d28798ebca196f38e1913f5cf481e98848615aeaa65023bc9722a25fe1466dfe57fdaebd9ed1e9a897300dc3b937dd401bfa8e9b SHA512 fbfddcdf0c8cc3d10f29677fba6ea44ce4653b30abecffcd38f9930cd09552750f83d5f02bff8706512623a4777a57fd0a9238ba3cbf26238bcd695ccfaaeb2b
MISC metadata.xml 673 BLAKE2B fb66f76592841f2647a94e24e07fafa8be2bc31583bac35dc3933a3feeea87f0c4105ab6b480bce5f2b8aeced8c113c8a3ce9714b22ff909f92eccceffa8f9a9 SHA512 9e758aa60153da583ed21bdf6addd001c560894fc6d429217405e7dfbdc673a9e22bc5a41afcc1281f7613ae1059c0824a7bba246006aa66c6eced75ab975e51
diff --git a/dev-python/pymongo/pymongo-3.12.1.ebuild b/dev-python/pymongo/pymongo-3.12.1.ebuild
new file mode 100644
index 000000000000..6466dfd4238f
--- /dev/null
+++ b/dev-python/pymongo/pymongo-3.12.1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit check-reqs distutils-r1
+
+MY_P=mongo-python-driver-${PV}
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
+SRC_URI="
+ https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+IUSE="doc kerberos"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ >=dev-db/mongodb-2.6.0
+ )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_sphinx doc
+distutils_enable_tests nose
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+src_prepare() {
+ # network-sandbox probably
+ rm test/test_srv_polling.py || die
+ sed -e 's:test_connection_timeout_ms_propagates_to_DNS_resolver:_&:' \
+ -i test/test_client.py || die
+ # relies on exact exception message
+ sed -e 's:abstract methods:abstract:' \
+ -i test/test_custom_types.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}