summaryrefslogtreecommitdiff
path: root/dev-python/pynotifier
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pynotifier
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pynotifier')
-rw-r--r--dev-python/pynotifier/Manifest3
-rw-r--r--dev-python/pynotifier/metadata.xml13
-rw-r--r--dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pynotifier/Manifest b/dev-python/pynotifier/Manifest
new file mode 100644
index 000000000000..1352294858ae
--- /dev/null
+++ b/dev-python/pynotifier/Manifest
@@ -0,0 +1,3 @@
+DIST pynotifier_0.7.0.orig.tar.gz 35358 BLAKE2B e709401b1667f8b902b70d7a1b1606fc492b2be073dc1325789db1a992ca1bf35363057566357f34fc360d28237090d00fafd621253cf86036ea6075d96252b7 SHA512 60be00e5a729c3bb3a6f778025e2422268986645bcb461a81db457cb8e4c94b86d7215d7725f0bc9dd1ea1dfaa16a879760c53dd6824fb398d02b7dc8979c3ef
+EBUILD pynotifier-0.7.0-r3.ebuild 749 BLAKE2B 3036a0caa9218894823dbfc1aa4abd5d9a2470c22caa14c0c222683156b7c262dd87820a80436b0b2e696006139abc5f265c9d251f332c2887daacb3355e391f SHA512 5bb287402dc4bf10545ceff3cd89a384db13d086d8c844f23694ca130f14b5e46830cd3e63fa6280478543da130dc49c5097458272e17c01efc3ef3a7166589e
+MISC metadata.xml 438 BLAKE2B 3cb57b4366901fbb51f4844d596f42ba3adb5c49fe0ea2225ed3253ed73b9aaf3c405c8d23ff61c7784f071a2f4b62b8573c6719c732cfe9d377ab550b61e06d SHA512 7c76ac9bad501f1bf9bad003d7a30c68c70e8e6515f859a953f7176d3749087fb9f342b22ef0587ec01b810b96c0081371a772f8a0c5114ea20e7348526e41d2
diff --git a/dev-python/pynotifier/metadata.xml b/dev-python/pynotifier/metadata.xml
new file mode 100644
index 000000000000..af88d08ae16b
--- /dev/null
+++ b/dev-python/pynotifier/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ pyNotifier provides an implementation of a notifier/event
+ scheduler and is capable of wrapping other notifier
+ implementations of GTK+, Qt and wxWidgets.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild b/dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild
new file mode 100644
index 000000000000..af5e1cea7fb1
--- /dev/null
+++ b/dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="pyNotifier provides an implementation of a notifier/event scheduler"
+HOMEPAGE="http://www.bitkipper.net/"
+SRC_URI="http://www.bitkipper.net/bytes/debian/dists/unstable/source/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="gtk"
+
+DEPEND=""
+RDEPEND="
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )
+ gtk? ( dev-python/pygobject:2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ if !use gtk; then
+ rm notifier/nf_gtk.py || die
+ fi
+ rm notifier/nf_qt.py || die
+ distutils-r1_python_prepare_all
+}