summaryrefslogtreecommitdiff
path: root/dev-python/pynput/pynput-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/pynput/pynput-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/pynput/pynput-9999.ebuild')
-rw-r--r--dev-python/pynput/pynput-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pynput/pynput-9999.ebuild b/dev-python/pynput/pynput-9999.ebuild
new file mode 100644
index 000000000000..a9c4160cc50b
--- /dev/null
+++ b/dev-python/pynput/pynput-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Sends virtual input commands"
+HOMEPAGE="https://github.com/moses-palmer/pynput"
+LICENSE="GPL-3"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/moses-palmer/pynput.git"
+else
+ SRC_URI="https://github.com/moses-palmer/pynput/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare(){
+ sed -i "s/ + SETUP_PACKAGES,/,/g" setup.py
+ distutils-r1_src_prepare
+}