summaryrefslogtreecommitdiff
path: root/dev-python/pyogg/pyogg-1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyogg/pyogg-1.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyogg/pyogg-1.3-r2.ebuild')
-rw-r--r--dev-python/pyogg/pyogg-1.3-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyogg/pyogg-1.3-r2.ebuild b/dev-python/pyogg/pyogg-1.3-r2.ebuild
new file mode 100644
index 000000000000..ec98a7defffd
--- /dev/null
+++ b/dev-python/pyogg/pyogg-1.3-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Python bindings for the ogg library"
+HOMEPAGE="http://www.andrewchatham.com/pyogg/"
+# Grumble. They changed the tarball without changing the name..
+#SRC_URI="http://www.andrewchatham.com/pyogg/download/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}-r1.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=media-libs/libogg-1.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( COPYING ChangeLog )
+
+python_configure_all() {
+ tc-export CC
+ "${PYTHON}" config_unix.py --prefix /usr || die "Configuration failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*
+}