summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-11 12:07:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-11 12:07:11 +0000
commit44a6f923079d51164af67c7bc3f3e0db24658088 (patch)
tree887711eae2249a5c6ddbd27a28150c485e7b5475 /dev-python/pyopencl
parent81e061dafc8bba274946b1e96d43863977187080 (diff)
gentoo auto-resync : 11:03:2023 - 12:07:11
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest4
-rw-r--r--dev-python/pyopencl/pyopencl-2022.2.4.ebuild70
-rw-r--r--dev-python/pyopencl/pyopencl-2022.3.1.ebuild11
3 files changed, 7 insertions, 78 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index e316bb0fc6f6..0d9365bed43f 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,5 +1,3 @@
-DIST pyopencl-2022.2.4.tar.gz 468743 BLAKE2B 52c0d1bfc1f01eef853efb334434eba81adfaa57d98592663145b3124110765f2afa936331e36b534abadf8d87a5c606ab32ab4452e0b8e87f1ee41c1ef2548c SHA512 b1996dec89a6921216d624e5e38407dd7ada77f137e9c245f9c2dd634dd33d208ffdad57f84739e7942c64643c37ea2d044277fed85eefb362bbc331f4be3ab0
DIST pyopencl-2022.3.1.tar.gz 470441 BLAKE2B 86ec602f3d73a64e34fe77b7985e64db332a685b33231ad7832d7e864f3170e3eee0aed42742b9892f7950a0f672a736e169ccd0ca08a124b7f20738b348dbff SHA512 57944de69bb24f0f22fb2c0165cd4de5265f5329246fead8449d26e6cbe1204fd44ced70df9960aa54e7d285abe81d8f8a802ba62309de5f4865e882177025ae
-EBUILD pyopencl-2022.2.4.ebuild 2043 BLAKE2B 129157f9e2ca1ca81ce356082aae9a09695179857864d759ce11a04d5746bf06c44d60d9834c1da012dbab913c58d618c178abb88b21616cb29ab357ea851326 SHA512 aec768ce78cb93ba04805cb26388a5b39dc953a705c2028938376964370d68ae6ad07c48859449593724e27ec714f12a6b8e96d80fd01825b014feb44d877f36
-EBUILD pyopencl-2022.3.1.ebuild 2044 BLAKE2B 4c714fe77cf73a6b356fdc8b0f8e8ad3f71d8c43b7a22916652918ae3315e83c74346d91b5e547d0efa84d58d5ca2a32e092b52c0de8a63b2a56faf97f599232 SHA512 32557bc9557d4232ac627cf9eca80abc649ed81224388b68b6070bf70955da5ca2824ccb8f640fa97d0c4625fce585157a5060d8c73143480d3ed83ab8c610eb
+EBUILD pyopencl-2022.3.1.ebuild 1999 BLAKE2B d64eb47dc442534e666b141e7d02bde62d80ead50d74cbde05dc32b28b143f20e1e6ceab3c199720ae07fa4e26272c034484ee8cd2962ba98dfc9f5db9cf4346 SHA512 d339449a1043befbf8eacbdb9f6874b16be9b54fcc17c0c1070ac4176fccdc04fb488dcef44555031d5aed30179bb3a74684240ec980dc66c67b7b63be1f34ac
MISC metadata.xml 373 BLAKE2B 0de89cb91a5dba1c34bacf04a95d4e2eb9e903bfb55e291f2ed20d579b9736a9a25f27620eed05d19c903c117e0dfbf410f408e9ff4008ce8c93f7b1b004141e SHA512 4ff5643089e5590d1ae4ef413a1ab0fa2772f71922a9da2c8b43ae375ba2e6e3d95ab90a13d51d22fdea49663c112c36352df609eceebd520fdc06590907b0e7
diff --git a/dev-python/pyopencl/pyopencl-2022.2.4.ebuild b/dev-python/pyopencl/pyopencl-2022.2.4.ebuild
deleted file mode 100644
index 5b660b8c377c..000000000000
--- a/dev-python/pyopencl/pyopencl-2022.2.4.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64"
-IUSE="examples opengl"
-
-# Running tests on GPUs requires both appropriate hardware and additional permissions
-# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
-# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
-RESTRICT="test"
-
-COMMON=">=virtual/opencl-2"
-# libglvnd is only needed for the headers
-DEPEND="${COMMON}
- opengl? ( media-libs/libglvnd )"
-RDEPEND="${COMMON}
- >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
- test? ( dev-libs/pocl )"
-
-distutils_enable_tests pytest
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_test() {
- # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
- local -x PYOPENCL_TEST="portable:pthread"
- # Set the number of threads to match MAKEOPTS
- local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
- # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
- # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
- pushd test >/dev/null || die
- epytest
- popd >/dev/null || die
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyopencl/pyopencl-2022.3.1.ebuild b/dev-python/pyopencl/pyopencl-2022.3.1.ebuild
index ca30dc274779..c5b324926a54 100644
--- a/dev-python/pyopencl/pyopencl-2022.3.1.ebuild
+++ b/dev-python/pyopencl/pyopencl-2022.3.1.ebuild
@@ -6,16 +6,17 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 multiprocessing
+inherit distutils-r1 multiprocessing pypi
DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/
+"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
+KEYWORDS="amd64 ~ppc64"
IUSE="examples opengl"
# Running tests on GPUs requires both appropriate hardware and additional permissions