summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pyopencl
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest4
-rw-r--r--dev-python/pyopencl/pyopencl-2017.2.ebuild5
-rw-r--r--dev-python/pyopencl/pyopencl-2019.1.2.ebuild56
3 files changed, 62 insertions, 3 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index c710423311a3..bd245e5d3a51 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,5 @@
DIST pyopencl-2017.2.tar.gz 350145 BLAKE2B 12c481893158f97dec612256b36e710ab52356c8b5f644f3710b5e34d4d10df3b27137ad76f29543fe16b3da725471e206aa5f69c646a79a65246d6091c686a9 SHA512 49f2ff619d8c214a3962b8444e68ba415dda032abaf9eeab259fcd1b21fbaab10bd057035161baef7f0182995834082218a6667464c01645231a94c88aa5c18b
-EBUILD pyopencl-2017.2.ebuild 1271 BLAKE2B 39065f9b777f85306a3885ca00064b964035e220267f8b8e0cf54dcaced4bce7817c3de392dc088e12cc851f681da7424fb319a83871bd3ac1b24a32449b2c96 SHA512 4bde1ea332d0121b68135a27c1a6b7455d5c26b5963b8ac4981860fb6eecd6c044603221f9cc4d194c1ddf210d7fa3b5458aa6d92a48e131803fc7750d4cef8a
+DIST pyopencl-2019.1.2.tar.gz 343805 BLAKE2B 027b231231532403a5e18249bd438e1a5a67805a685e46fd9506f7286957b14068540f93a3733149aeba2a720f6c71e91db74351916ca974739374a05f2d2c74 SHA512 b2850622253f480cafacadbb9d13afea801af9d4dd52679f132fc0e5f1d4c2f4d3bdf83c9ed64c14c19ead75e6d36afa8b57ff52bbea135fc02291b1fe7b8636
+EBUILD pyopencl-2017.2.ebuild 1219 BLAKE2B 80a2e42ad3cbd12c9eab55a7610fde71058f4041619a17ea7c96545f5fcbc883e50ad585c8828a87ebde6579cfb8c548538b75b459728aef16e77da548b56763 SHA512 1939664e9d5fc88a6a88a65eb96f6371c6e39fa3b94b045ef26bc75b1b34bf232824528375d697dd17eecac80383c5503c76ef8eae906f615a62ec41216de83d
+EBUILD pyopencl-2019.1.2.ebuild 1224 BLAKE2B ea3fae39e976b0ca9826bd40b27be191f609878c05a588d1c0bbc358d7ccafd93e0fc3f3a52e3ab1ace784e26809265087b771763070b69576987f2e8433180e SHA512 a71f221152be91ab54a9976a263a77edd0572d2d3561646c7b1d9ff70cbeb185f61cae20085aaa7fc2ce6b0681a947a19b8d2a9712fe2c4e86c3cf567e7de8ad
MISC metadata.xml 311 BLAKE2B 4a843a4ed6ec77f0be47c898b7fc2a402f486d28dabd347983b1ab528e98173babd5f87270183812cf3d5f6cde6866e1a999e750e3dcdb1411d8b3f029eb10cb SHA512 14da0f2cb9db48698adc78e6827c161a93ac3307c0a595fbf69c45839dac9178966fa855193adf2f175685b7be31eb161c0281b3a35ef2e455db62f0ba65dde5
diff --git a/dev-python/pyopencl/pyopencl-2017.2.ebuild b/dev-python/pyopencl/pyopencl-2017.2.ebuild
index 16d173abc647..f27666755022 100644
--- a/dev-python/pyopencl/pyopencl-2017.2.ebuild
+++ b/dev-python/pyopencl/pyopencl-2017.2.ebuild
@@ -44,8 +44,9 @@ src_configure() {
python_install_all() {
if use examples; then
- local EXAMPLES=( examples/. )
- einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
distutils-r1_python_install_all
}
diff --git a/dev-python/pyopencl/pyopencl-2019.1.2.ebuild b/dev-python/pyopencl/pyopencl-2019.1.2.ebuild
new file mode 100644
index 000000000000..436d47db04a2
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2019.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2017.5[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-2"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ --cl-pretend-version=1.2 \
+ "${myconf[@]}"
+}
+
+python_test() {
+ cd "${S}/test" || die
+ pytest -vv || die "Testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}