summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
commit90a3be9d71a22834f9bc82c072f1b993f9a10e31 (patch)
tree7f86c1f37e857df29494ec91436ca76bed49441a /dev-python/pyopencl
parenta597364520b9291d0b2a23bb007ced022e821d95 (diff)
gentoo auto-resync : 20:08:2023 - 21:42:17
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest3
-rw-r--r--dev-python/pyopencl/files/pyopencl-2023.1.2_numpy-include-dir.patch16
-rw-r--r--dev-python/pyopencl/pyopencl-2023.1.2.ebuild76
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 1454a13bf00e..f4ca31882204 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,6 @@
+AUX pyopencl-2023.1.2_numpy-include-dir.patch 409 BLAKE2B 54b6f0618d1988d7bb83f42b289d4eea30bce992a757a20d2d6e401261497ed4a2e1a302f5b59d840d64b9f5649c0b3f137eb98634ee2122d695177c161d9a46 SHA512 672f4fbe11fa91bbce354898f5beda783e9fe907614b336b5dfee5dfbf5ef4e82cb9b70d7e9866c221f2044a06e5ea9c630adfdd0db3c1c46233debb1f0203c3
DIST pyopencl-2023.1.1.tar.gz 472723 BLAKE2B 4960db0b9096ef624f0459f6711a6d1fc4561599f96c3b01c5efe3c183c8cc4284b63038b2a5e98d43c194a8e5ce3331886f675c0bc5f44073bc353675400985 SHA512 50c23132028bb2c35816b6c83c054eaf929d333fbb172230e0d696a5e6103ad6ee6ccbbbd0b5d3d2d3c5f02505340a885422097eccecb1bf51845658c7938c8f
+DIST pyopencl-2023.1.2.tar.gz 473684 BLAKE2B 3912885395df515f3e935149c0bac618c371b75791ac670d1a2cd25ffe5e3ff1c4d0e82d8a475e26d3280aaa659d900ed7df66b3f6952f54266d3cd2ad3b44c2 SHA512 3414b011f0bd0420df4725904b715d54bad0ae77cb4b8619d8d769cd25b56d44a8d34788c23de80b5da5ae757f38231db980f3abcb2544117b7be7627592bf0e
EBUILD pyopencl-2023.1.1.ebuild 2100 BLAKE2B 4854fd9f195f70a703a9e7a7497556aa9817f2d67814b9204594d72621ba064d70ad07672117d01d50e1cc344cb43d99034515e07130e81fd397b5c6c22d2719 SHA512 71c44d37e5a1205f1b0dd74ff7f03348f23807ea846b05c72574be5d7c1550489d81a3fd1d3ffdd486d134d4945dce2b4c2f6558e2297c85d26ad3b3e90a024f
+EBUILD pyopencl-2023.1.2.ebuild 2091 BLAKE2B e4b12aeeea5f8f94c115d65d6c6c6ac9494a50021f6dc663e98bab0aa195ff3dab05ca820aa8d86b6147ce4013be6257c27ee36ac6cb005b09c2d9de477bf21c SHA512 248d334cb221a856007497e713765f87ebf3b7dd6f6c51a4fc00cf1ca6c85668fbb967f16397cf210f1c493426213f1c585f4a4e20db12f808c52f898df90e21
MISC metadata.xml 373 BLAKE2B 0de89cb91a5dba1c34bacf04a95d4e2eb9e903bfb55e291f2ed20d579b9736a9a25f27620eed05d19c903c117e0dfbf410f408e9ff4008ce8c93f7b1b004141e SHA512 4ff5643089e5590d1ae4ef413a1ab0fa2772f71922a9da2c8b43ae375ba2e6e3d95ab90a13d51d22fdea49663c112c36352df609eceebd520fdc06590907b0e7
diff --git a/dev-python/pyopencl/files/pyopencl-2023.1.2_numpy-include-dir.patch b/dev-python/pyopencl/files/pyopencl-2023.1.2_numpy-include-dir.patch
new file mode 100644
index 000000000000..7a5ce5f52bdc
--- /dev/null
+++ b/dev-python/pyopencl/files/pyopencl-2023.1.2_numpy-include-dir.patch
@@ -0,0 +1,16 @@
+--- a/aksetup_helper.py
++++ b/aksetup_helper.py
+@@ -43,11 +43,8 @@
+
+
+ def get_numpy_incpath():
+- from imp import find_module
+- # avoid actually importing numpy, it screws up distutils
+- file, pathname, descr = find_module("numpy")
+- from os.path import join
+- return join(pathname, "core", "include")
++ import numpy as np
++ return np.get_include()
+
+
+ class NumpyExtension(Extension):
diff --git a/dev-python/pyopencl/pyopencl-2023.1.2.ebuild b/dev-python/pyopencl/pyopencl-2023.1.2.ebuild
new file mode 100644
index 000000000000..b25bb0a7ec5d
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2023.1.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="
+ https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+IUSE="examples opengl"
+
+# Running tests on GPUs requires both appropriate hardware and additional permissions
+# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
+# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
+RESTRICT="test"
+
+COMMON=">=virtual/opencl-2"
+# libglvnd is only needed for the headers
+DEPEND="${COMMON}
+ opengl? ( media-libs/libglvnd )"
+RDEPEND="${COMMON}
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ test? ( dev-libs/pocl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2023.1.2_numpy-include-dir.patch
+)
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_test() {
+ # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
+ local -x PYOPENCL_TEST="portable:pthread"
+ # Set the number of threads to match MAKEOPTS
+ local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
+ # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
+ # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
+ pushd test >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}