summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-09 12:24:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-09 12:24:59 +0100
commitc218398bbbe70a616790cf146c28c1066b9284bf (patch)
treea598e8c85afbc52bb7eca18ae415ef4971e65c8f /dev-python/pyopencl
parenta5442e2318cb4df55867389654e322dbac82067e (diff)
gentoo auto-resync : 09:07:2024 - 12:24:58
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest3
-rw-r--r--dev-python/pyopencl/files/pyopencl-2024.2.7-nanobind-flags.patch13
-rw-r--r--dev-python/pyopencl/pyopencl-2024.2.7.ebuild78
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 2104f6cedb18..8870e5e79570 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,6 @@
+AUX pyopencl-2024.2.7-nanobind-flags.patch 478 BLAKE2B 2e928f54d7275ea04ca5635f281f06e26690155299024939dc398a37858c6cb07193ab81f90a7a33602e69b0912ab4268349428ed7748e720d1033a18bdbae48 SHA512 6a71b6bcea720e1ce0b0c08682c1301176ba0286fc90bcb16757c2acef955b3fb2cea04f25193ff18583067e6640d8a35ae5980bd19995d9947ec83936a519ef
DIST pyopencl-2024.1.tar.gz 473860 BLAKE2B 803c92418a609f3ad9249c81e93af0bd2e9125ee56dc88af8ee6ae9c4a275c7ab37befddd575914eb9f0b295aaef4f135358669e384a55c04b3938b02572724d SHA512 abf27d67f8c3633c71e662938a919c88a34b0b66cc3c213644f92a8733aed3c9b7593542dd9b45a080941976dadeb4f49a23a986482110824b554e3a0d317176
+DIST pyopencl-2024.2.7.tar.gz 470964 BLAKE2B 6c61d91735667dd63fec0375defe98fb681eb448780f86b0129769d30714adb51832955d8c2e838970f17187e5027f794cd21affc870910d23ec46126049d4ed SHA512 5c9982f5dcaeb3faeb6ac6b88940b5baff43b7580fc5d466a596d9c180e45725cbf9971ba6ae4981202900b06cee3be7fa88fdf7227befee874a8f203a3a3267
EBUILD pyopencl-2024.1.ebuild 2023 BLAKE2B 6088a13394451d8ce78f521fb3dfde49ae96df2be6444c60d176203a252e5220b9d23b855adbd552606c1f6a612541eb49f1d85b313baa96814b202e74ec6c60 SHA512 84fa66010684576ea2c62f2d72f85d64a9ca561b90aa3ed9c51fce39e605bbf71d9532d45b3c6dfbc199ad9e245c4a14223947aff3235608511c83d1ccdde27a
+EBUILD pyopencl-2024.2.7.ebuild 2028 BLAKE2B e2ceda78c66a37303c3e33aa9ea7e0441b1502ae384807d94601b2718d0a1c89094c5d37ea5c50a1655f6def2e319f31258ab73703338c84bdbe7be187bc3a21 SHA512 c8c6c586d033750613f59f14fcbf674839424ba3df8755c6bf3be2e7aeb0c39dccf4ee6a07495d9caac18959ec9758845f7e3d0236acdcd7cffbc8300f7ef8e5
MISC metadata.xml 295 BLAKE2B ebe147867a9ecd3559e288e4fda56c04def2b224d87d6561d9065b13b251182f871b510acfd5034e63fc034d507837c241a6d1c639deda94faba05d3d020a285 SHA512 28117a5f3351192d7d3a58cdf47e8403155e027fd85ccbf5af32e5df9df59909d89ea94b18351354c312c323aa5e217da3b4a99e17cfbf59f307ddb4a38bc707
diff --git a/dev-python/pyopencl/files/pyopencl-2024.2.7-nanobind-flags.patch b/dev-python/pyopencl/files/pyopencl-2024.2.7-nanobind-flags.patch
new file mode 100644
index 000000000000..e5816b924773
--- /dev/null
+++ b/dev-python/pyopencl/files/pyopencl-2024.2.7-nanobind-flags.patch
@@ -0,0 +1,13 @@
+nanobind defaults to adding -Os and friends: https://github.com/wjakob/nanobind/blob/b0136fe6ac1967cb2399456adc346a1af06a3b88/docs/api_cmake.rst#L80.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -167,6 +167,9 @@ find_package(OpenCL REQUIRED)
+ nanobind_add_module(
+ _cl
+ NB_STATIC # Build static libnanobind (the extension module itself remains a shared library)
++ PROTECT_STACK
++ NOMINSIZE
++ NOSTRIP
+ src/wrap_constants.cpp
+ src/wrap_cl.cpp
+ src/wrap_cl_part_1.cpp
diff --git a/dev-python/pyopencl/pyopencl-2024.2.7.ebuild b/dev-python/pyopencl/pyopencl-2024.2.7.ebuild
new file mode 100644
index 000000000000..33db2359adeb
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2024.2.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=scikit-build-core
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="
+ https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+# Running tests on GPUs requires both appropriate hardware and additional permissions
+# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
+# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
+RESTRICT="test"
+
+COMMON=">=virtual/opencl-2"
+# libglvnd is only needed for the headers
+DEPEND="
+ ${COMMON}
+ opengl? ( media-libs/libglvnd )
+"
+RDEPEND="
+ ${COMMON}
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2024.1.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/nanobind[${PYTHON_USEDEP}]
+ test? ( dev-libs/pocl )
+"
+
+PATCHES=(
+ "${FILESDIR}"/pyopencl-2024.2.7-nanobind-flags.patch
+)
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ -DPYOPENCL_ENABLE_GL=$(usex opengl)
+ )
+}
+
+python_test() {
+ # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
+ local -x PYOPENCL_TEST="portable:pthread"
+ # Set the number of threads to match MAKEOPTS
+ local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
+ # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
+ # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
+ pushd test >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}