summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-25 20:05:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-25 20:05:44 +0000
commitd117172e3b48fc4be82b7623ffc40bb6070ef361 (patch)
tree20abd806f41d6a3c1699561a0f81279763e9253d /dev-python/pyopencl
parent5950ab0f26bdbfcc40b68a19fd542816fecdd615 (diff)
gentoo auto-resync : 25:12:2022 - 20:05:44
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest4
-rw-r--r--dev-python/pyopencl/pyopencl-2022.2.3.ebuild70
-rw-r--r--dev-python/pyopencl/pyopencl-2022.2.4.ebuild2
3 files changed, 2 insertions, 74 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 2e22e7133184..c8463b6de09a 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,5 +1,3 @@
-DIST pyopencl-2022.2.3.tar.gz 468218 BLAKE2B d747014c4cdb4d4303aa03fa16606f032b193497cf20909fd9e449f3c02e3d61dce55e44e93e769e4ec8f9c5f859c8d0a0f13bca1f1350dd7a29f6d92bcc3429 SHA512 b16feaa6d8a00cebb4f8c87d2aabed3472c45484eb5ecd530cb8e3478cfc9a41386203ab8cac0450b211f3330c36b3c52846e73a31e346784182f2ca9e6f4123
DIST pyopencl-2022.2.4.tar.gz 468743 BLAKE2B 52c0d1bfc1f01eef853efb334434eba81adfaa57d98592663145b3124110765f2afa936331e36b534abadf8d87a5c606ab32ab4452e0b8e87f1ee41c1ef2548c SHA512 b1996dec89a6921216d624e5e38407dd7ada77f137e9c245f9c2dd634dd33d208ffdad57f84739e7942c64643c37ea2d044277fed85eefb362bbc331f4be3ab0
-EBUILD pyopencl-2022.2.3.ebuild 2043 BLAKE2B 71bc88e3ce59a64612e91dbe1985f198815e9e0f13e3773b13c26ef101ecbaa88279026640d342c6ba7b0d500da36b6c6d9f8320c3104183e66953e648749bbb SHA512 eb1d85310e0a24ca3ca280c3d0d40e0c189c31ec0e0d152ad0838521ae5b1538d697129b0d1ac1edd075128af28cccd4f00b661d913f404179b023d4ff4e0eab
-EBUILD pyopencl-2022.2.4.ebuild 2044 BLAKE2B 6083d65ab5496d9291bb4b7fceb41b5fc1edc466f4151be6ddc4770311c956f7e310d668fa811b37c568b7010bf59d7fd2b4f6a8434cb6f5982c9e5b20f17a2c SHA512 90255f6c485fc35319289dfe3945b459892d99801645a5bbaf08c52f1c8f0b63587ff2d62a5d8f75f24e13f9e66f0197ea98e43420ac8ea435770334ff51b669
+EBUILD pyopencl-2022.2.4.ebuild 2043 BLAKE2B 71bc88e3ce59a64612e91dbe1985f198815e9e0f13e3773b13c26ef101ecbaa88279026640d342c6ba7b0d500da36b6c6d9f8320c3104183e66953e648749bbb SHA512 eb1d85310e0a24ca3ca280c3d0d40e0c189c31ec0e0d152ad0838521ae5b1538d697129b0d1ac1edd075128af28cccd4f00b661d913f404179b023d4ff4e0eab
MISC metadata.xml 373 BLAKE2B 0de89cb91a5dba1c34bacf04a95d4e2eb9e903bfb55e291f2ed20d579b9736a9a25f27620eed05d19c903c117e0dfbf410f408e9ff4008ce8c93f7b1b004141e SHA512 4ff5643089e5590d1ae4ef413a1ab0fa2772f71922a9da2c8b43ae375ba2e6e3d95ab90a13d51d22fdea49663c112c36352df609eceebd520fdc06590907b0e7
diff --git a/dev-python/pyopencl/pyopencl-2022.2.3.ebuild b/dev-python/pyopencl/pyopencl-2022.2.3.ebuild
deleted file mode 100644
index 6555792f7d0d..000000000000
--- a/dev-python/pyopencl/pyopencl-2022.2.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64"
-IUSE="examples opengl"
-
-# Running tests on GPUs requires both appropriate hardware and additional permissions
-# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
-# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
-RESTRICT="test"
-
-COMMON=">=virtual/opencl-2"
-# libglvnd is only needed for the headers
-DEPEND="${COMMON}
- opengl? ( media-libs/libglvnd )"
-RDEPEND="${COMMON}
- >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
- test? ( dev-libs/pocl )"
-
-distutils_enable_tests pytest
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_test() {
- # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
- local -x PYOPENCL_TEST="portable:pthread"
- # Set the number of threads to match MAKEOPTS
- local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
- # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
- # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
- pushd test >/dev/null || die
- epytest
- popd >/dev/null || die
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyopencl/pyopencl-2022.2.4.ebuild b/dev-python/pyopencl/pyopencl-2022.2.4.ebuild
index 253582817f5b..6555792f7d0d 100644
--- a/dev-python/pyopencl/pyopencl-2022.2.4.ebuild
+++ b/dev-python/pyopencl/pyopencl-2022.2.4.ebuild
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
+KEYWORDS="amd64 ~ppc64"
IUSE="examples opengl"
# Running tests on GPUs requires both appropriate hardware and additional permissions