summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pyopenssl/pyopenssl-22.0.0.ebuild')
-rw-r--r--dev-python/pyopenssl/pyopenssl-22.0.0.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
index c2f361933d05..f03b92cd9574 100644
--- a/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
+++ b/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
@@ -4,13 +4,14 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 toolchain-funcs
MY_PN=pyOpenSSL
MY_P=${MY_PN}-${PV}
+
DESCRIPTION="Python interface to the OpenSSL library"
HOMEPAGE="
https://www.pyopenssl.org/
@@ -22,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
RDEPEND="
>=dev-python/cryptography-35.0[${PYTHON_USEDEP}]
@@ -41,7 +42,12 @@ distutils_enable_sphinx doc \
dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
-src_configure() {
+src_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+
# test for 32-bit time_t
"$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} -c -x c - -o /dev/null <<-EOF &>/dev/null
#include <sys/types.h>
@@ -49,22 +55,13 @@ src_configure() {
EOF
if [[ ${?} -eq 0 ]]; then
- PYOPENSSL_SKIP_LARGE_TIME=
einfo "time_t is at least 64-bit long"
else
- PYOPENSSL_SKIP_LARGE_TIME=1
einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
fi
-}
-
-python_test() {
- local -x TZ=UTC
- local EPYTEST_DESELECT=(
- tests/test_ssl.py::TestContext::test_set_default_verify_paths
- )
- [[ ${PYOPENSSL_SKIP_LARGE_TIME} ]] && EPYTEST_DESELECT+=(
- tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
- )
- epytest
+ distutils-r1_src_test
}