summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
commit2a3c08f4647671d17f534a5dbd8bd45e11c90ea2 (patch)
tree67ecd2d13b251a03c4834bdec638d301818901eb /dev-python/pyopenssl
parenta2148b9fab4c83209816a49f091d70873b19881d (diff)
gentoo auto-resync : 29:11:2024 - 02:06:03
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest2
-rw-r--r--dev-python/pyopenssl/pyopenssl-24.3.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 2478d461f290..d9fa8b521d02 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,3 +1,5 @@
DIST pyopenssl-24.2.1.tar.gz 184323 BLAKE2B 5d077508c45c56b1da886877fb41e18699f932933badb73b271ce6d55fbf985398f5a74187fe65fde79b60768cb1705daf805f6fb8570f66ad3cecf11ad9b1c3 SHA512 4d0cdf71a5ae785644bd466ef094592fbf4ab804de8d153c139a88d3ff9b8cc80d073f3d49d4dc73d8ebf97a867e1560a5308b998f7ef0ccc734dcc56697c831
+DIST pyopenssl-24.3.0.tar.gz 178944 BLAKE2B ba3117c3c1238ecc84dfdbc84beaeb47c2d12d9e7f2742f798816482954696fd61405884780726f902f7784407e47f129cc5c38f7cf4cd76df4511d215ea4e4c SHA512 ca46a56a5c97ac91d1cbe1cb8b4d9e6d84610785736e925a579560802c1dce6b1cd95c0fed5c25aa775be8a4ae514c5962a86f2db5ecab4506e67ba80ebebd44
EBUILD pyopenssl-24.2.1.ebuild 1378 BLAKE2B 7e76254185844940363f56e1c9088ce0ee92725da093fa3378f53c73b57555e790c2ebfd565cdc12dd166ea86c81a00532dcf9d3c8d5bc84d91117dfd911826e SHA512 7eb1453dce2e3289b90c918dae3ab9e7fac648ad9b7302115cf73b6f6ba186fc47a07339ab412a6d9ed43bc33108ff93136f543e453b01259f62a14591deef03
+EBUILD pyopenssl-24.3.0.ebuild 1385 BLAKE2B 5b067304a141182923613119fd599e768626765af9f10809fe1939d9e28f71566dee1b02a8560b598c5f64ce58bb89ffbf8f2f5edc14da0444d636b826992195 SHA512 bb97aa1da7140f341c7fab4932cbbae7563a22940cdee99b5c7d61d589be9c3a5641cba1c35aee71518ffe07efeb2e762b28e1badf40095ec4120422ab863a46
MISC metadata.xml 536 BLAKE2B 86db822042b6fb3e965ece87b6b15dcabf76cdfbfa76ba285a491208ad5c6a2a196ca7144a1a73b152decc4df1641ad4c57a1cbde9f90d09d25eef1f6f4da39a SHA512 996d0e20291e744c6c20b38fd750d242920541aca7d92de63ca5b1dcc2f1c10308545797ccf499f38e50dfd04db2bb031e93b02c7c1705908f2363c813294ff1
diff --git a/dev-python/pyopenssl/pyopenssl-24.3.0.ebuild b/dev-python/pyopenssl/pyopenssl-24.3.0.ebuild
new file mode 100644
index 000000000000..d65c2e37ea07
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-24.3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=pyOpenSSL
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ https://www.pyopenssl.org/
+ https://github.com/pyca/pyopenssl/
+ https://pypi.org/project/pyOpenSSL/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/cryptography-45[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-41.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+
+ if ! tc-has-64bit-time_t; then
+ einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ epytest -p rerunfailures
+}