summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/pyopenssl
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest2
-rw-r--r--dev-python/pyopenssl/pyopenssl-19.0.0.ebuild68
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index cb5472a911a6..0df67dbd1be6 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,5 +1,3 @@
-DIST pyOpenSSL-19.0.0.tar.gz 168551 BLAKE2B 762d3358b3cc4f1e088e9464ac079e5212c537d25691e51edb3255a192c42276506c758ecf16eff999082bfd05aeb92a37741338d92036d2149b87c95008db05 SHA512 a7e12bf5be725ccebd1223d567a9b9e8bd35f79cbf3a0409108fa6f00e10ab137dd6876369e9dede02b2abc7d700786cc905532ca5c31b6e246f6df8b24e2818
DIST pyOpenSSL-19.1.0.tar.gz 160510 BLAKE2B e6e39f860221a2696aa3fa32ac89ed48e34b18e4accc366a86264d943a15a1b00ba1a0d8349550d1775d25836aa5d214e1e3fe4ec0a9c0f6d5ab00cd9fede633 SHA512 4acd96f287d72eb11bd812697d28cd6eb6a96a4653248b65f967187830a6b17cc1254775a18a3405469f3d45abdae6f02d165f2f35f035f3174c2826fba82916
-EBUILD pyopenssl-19.0.0.ebuild 1730 BLAKE2B 888362f63063cc67511c372588e20726e75a0335777b61d50efbaada92f7cefdf059ab829b301ec21f0a1353305ef5415998dd57eb9268c12b3befabd24465ab SHA512 b0ad06edad83d396a15488c4ef601bbdb94bc3e4438db0ffadf003cc7c5092aec5ea15d316fdeef2eaef6522966ea7ade26c83afc7e126a5f8b48f76826bdd66
EBUILD pyopenssl-19.1.0.ebuild 1396 BLAKE2B 2b441d8c1c57d6fd34387e294edefac97a357605e65f637b248d0e1ae96f7133c8ee3590692eac8d363971e7a49399152eb0a4c7cac3307e9cd1db98402eee75 SHA512 f35471f7b55d3c91a209725b4619aae02cdb398b27b882d18eb6dd3b49409d22111c329a039e85057579ded328bf4d249b4c8b15b573c7b07840c506c2316bf3
MISC metadata.xml 418 BLAKE2B 69f135bab3b0cffa47cc8e807e1f537f7fa0bd599bf3309ab92ddf41f894c21ab0e3f793ea4caa65d272043d2dc0352fc54c7160b31fccabbeb165775a895d97 SHA512 5cd4b0381e79245626500a2a38b9f7bedcc8e4742445ac16f12a96133f1291ec49592f2259294f153d5f1b27969cd6f7f364d49f32d0793b12b2ad38b824f441
diff --git a/dev-python/pyopenssl/pyopenssl-19.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-19.0.0.ebuild
deleted file mode 100644
index 73e7cfca8c2f..000000000000
--- a/dev-python/pyopenssl/pyopenssl-19.0.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN=pyOpenSSL
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the OpenSSL library"
-HOMEPAGE="
- http://pyopenssl.sourceforge.net/
- https://launchpad.net/pyopenssl
- https://pypi.org/project/pyOpenSSL/
-"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- virtual/python-cffi[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
- )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- # Requires network access
- sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}