summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyopenssl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest3
-rw-r--r--dev-python/pyopenssl/metadata.xml13
-rw-r--r--dev-python/pyopenssl/pyopenssl-17.5.0.ebuild66
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
new file mode 100644
index 000000000000..e86bb8ed1750
--- /dev/null
+++ b/dev-python/pyopenssl/Manifest
@@ -0,0 +1,3 @@
+DIST pyOpenSSL-17.5.0.tar.gz 170870 BLAKE2B e8b8986a7c5475ac3898df4877a8be86db359af79e1718bad85149440cff543c501ee23eb369270d2c539a9e3f4e13165ea87b858ef6916ee79ca6e49f6e5370 SHA512 f194662b5842f1e3a4fcb910b9f2e6482d1dcdf834f306acc3dd6d9723f65038f7bff550248fa6268d90c839c9d9e8248bb6c7d399495fe6aed25291b93ece86
+EBUILD pyopenssl-17.5.0.ebuild 1668 BLAKE2B 0ebcafb540139e3831e9be00922411aa5722f925c976577428e026cfcc3ad457e853a9fb851dcb2f9ff0a621f3f5ecf4dcec12391a582f8e213a5ab6458c1c38 SHA512 42d968cbf25d851ad9e4d2534d2880ca1447bcc6eb9db0d947e32d09f7353d9be9b9f80ec606164883ef2e9dd951a1c06eaee87d69560cf4904e871592edb064
+MISC metadata.xml 418 BLAKE2B 69f135bab3b0cffa47cc8e807e1f537f7fa0bd599bf3309ab92ddf41f894c21ab0e3f793ea4caa65d272043d2dc0352fc54c7160b31fccabbeb165775a895d97 SHA512 5cd4b0381e79245626500a2a38b9f7bedcc8e4742445ac16f12a96133f1291ec49592f2259294f153d5f1b27969cd6f7f364d49f32d0793b12b2ad38b824f441
diff --git a/dev-python/pyopenssl/metadata.xml b/dev-python/pyopenssl/metadata.xml
new file mode 100644
index 000000000000..4497991b3740
--- /dev/null
+++ b/dev-python/pyopenssl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyOpenSSL</remote-id>
+ <remote-id type="launchpad">pyopenssl</remote-id>
+ <remote-id type="sourceforge">pyopenssl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild b/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild
new file mode 100644
index 000000000000..5321b415db30
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ http://pyopenssl.sourceforge.net/
+ https://launchpad.net/pyopenssl
+ https://pypi.org/project/pyOpenSSL/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ # Requires network access
+ sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}